source: projects/specs/branches/6/p/pyOpenSSL/pyOpenSSL-vl.spec @ 8248

Revision 8248, 6.3 KB checked in by iwamoto, 10 years ago (diff)

pyOpenSSL: new upstream release with security fix

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pkg_release     1%{?_dist_release}
4
5Summary: Python wrapper module around the OpenSSL library
6Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
7Name: pyOpenSSL
8Version: 0.13.1
9Release: %{pkg_release}
10
11Source0: http://pyopenssl.sf.net/%{name}-%{version}.tar.gz
12Patch3: pyOpenSSL-nopdfout.patch
13
14Group: Development/Libraries
15URL: http://pyopenssl.sourceforge.net/
16
17License: ASL 2.0
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: openssl-devel, python-devel
20BuildRequires: latex2html
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26High-level wrapper around a subset of the OpenSSL library, includes
27 * SSL.Connection objects, wrapping the methods of Python's portable
28   sockets
29 * Callbacks written in Python
30 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
31...  and much more ;)
32
33
34%prep
35%setup -q
36%patch3 -p1 -b .nopdfout
37
38# Fix permissions for debuginfo package
39# %{__chmod} -x src/ssl/connection.c
40%{__chmod} -x OpenSSL/ssl/connection.c
41
42%build
43CFLAGS="%{optflags}" %{__python} setup.py build
44%{__make} -C doc ps
45%{__make} -C doc text html
46
47%install
48%{__rm} -rf %{buildroot}
49%{__python} setup.py install -O1 --skip-build --root %{buildroot}
50
51%clean
52%{__rm} -rf %{buildroot}
53
54%files
55%defattr(-,root,root,-)
56%doc README doc/pyOpenSSL.ps
57%doc doc/pyOpenSSL.txt doc/html
58%{python_sitearch}/OpenSSL/
59%{python_sitearch}/%{name}*.egg-info
60
61%changelog
62* Sun Nov 10 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.13.1-1
63- new upstream release with security fix
64- patch3 from fc19 and drop old patches
65- change License to ASL2.0
66- add Vendor/Distri tags
67
68* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-3
69- rebuilt with openssl-1.0.0c
70- remove BuildRequires: tetex
71
72* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
73- rebuilt with python-2.6.4
74
75* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
76- initial build for Vine Linux based on fedora package
77
78* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
79- Rebuild for Python 2.6
80
81* Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
82- update threadsafe  patch
83- bug#462807
84
85* Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
86- bump to new release
87- the inevitable patch fixes
88
89
90* Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
91- fix horrific release tag
92- fix license tag
93- add egg-info
94
95* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
96- Autorebuild for GCC 4.3
97
98* Wed Dec  5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
99- rebuild for new openssl
100
101* Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
102- add missing buildreq latex2html, needed to build HTML docs
103- rewrite to be more in line with Fedora python spec template and use
104  %%{python_sitearch} rather than a script-generated %%files list
105- package is not relocatable - drop Prefix: tag
106- buildreq perl not necessary
107- fix permissions for files going into debuginfo package
108
109* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
110- rebuild for python 2.5
111
112* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
113- rebuild
114
115* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
116- bump again for double-long bug on ppc(64)
117
118* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
119- rebuilt for new gcc4.1 snapshot and glibc changes
120
121* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
122- rebuilt
123
124* Wed Nov  9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
125- rebuilt against newer openssl
126
127* Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
128- add dcbw's patch to fix some threading problems
129
130* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
131- current rpm creates .pyo files, include them in filelist
132
133* Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
134- rebuilt
135
136* Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
137- rebuilt
138
139* Mon Mar  7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
140- rebuild with openssl-0.9.7e
141
142* Tue Nov  9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
143- rebuild
144
145* Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
146- 0.6 is out
147
148* Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
149- release candidate
150
151* Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
152- rebuilt
153
154* Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
155- rebuilt
156
157* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
158- rebuilt
159
160* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
161- rebuilt
162
163* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
164- rebuilt
165
166* Wed Nov  5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
167- rebuilt against python 2.3.2
168
169* Fri Aug  8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
170- lynx no longer supported, using elinks instead (patch from
171  Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
172
173* Wed Jun  4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
174- Rebuilt
175
176* Wed Jun  4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
177- Built on 7.x
178
179* Mon Mar  3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
180- bug #73967: Added Requires: python
181
182* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
183- rebuilt
184
185* Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
186- bug #84803: Added patch to expose more flags
187
188* Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
189- installing to %%{_libdir}
190
191* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
192- rebuilt
193
194* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
195- rebuild
196
197* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
198- Add -I and -L flags for finding Kerberos headers and libraries, in case
199  they're referenced
200
201* Tue Dec  3 2002 Mihai Ibanescu <misa@redhat.com>
202- Fix for bug 73967: site-packages/OpenSSL not owned by this package
203- Adding hacks around the lack of latex2html on ia64
204
205* Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
206- 0.5.1
207
208* Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
209- Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
210  error of pushing 0.5pre previously, since it breaks rpm's version comparison
211  algorithm).
212- We use %%{__python}. Too bad I can't pass --define's to distutils.
213
214* Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
215- Building 0.5
216
217* Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
218- Added documentation
Note: See TracBrowser for help on using the repository browser.