source: projects/specs/branches/6/p/pth/pth-vl.spec @ 6364

Revision 6364, 5.4 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1Summary:        The GNU Portable Threads library
2Name:           pth
3Version:        2.0.7
4Release:        8%{?_dist_release}
5License:        LGPLv2+
6Group:          System Environment/Libraries
7URL:            http://www.gnu.org/software/pth/
8Source:         ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz
9Source1:        ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz.sig
10Patch1:         pth-2.0.7-dont-remove-gcc-g.patch
11Patch2:         pth-2.0.7-config-script.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14%description
15Pth is a very portable POSIX/ANSI-C based library for Unix platforms
16which provides non-preemptive priority-based scheduling for multiple
17threads of execution ("multithreading") inside server applications.
18All threads run in the same address space of the server application,
19but each thread has it's own individual program-counter, run-time
20stack, signal mask and errno variable.
21
22%package devel
23Summary:        Development headers and libraries for GNU Pth
24Group:          Development/Libraries
25Requires:       %{name} = %{version}-%{release}
26
27%description devel
28Development headers and libraries for GNU Pth.
29
30
31%prep
32%setup -q
33%patch1 -p1 -b .dont-remove-gcc-g
34%patch2 -p1 -b .config-script
35
36
37%build
38%configure --disable-static ac_cv_func_sigstack='no'
39
40# Work around multiarch conflicts in the pth-config script in order
41# to complete patch2. Make the script choose between /usr/lib and
42# /usr/lib64 at run-time.
43if [ "%_libdir" == "/usr/lib64" ] ; then
44    if grep -e '^pth_libdir="/usr/lib64"' pth-config ; then
45        sed -i -e 's!^pth_libdir="/usr/lib64"!pth_libdir="/usr/lib"!' pth-config
46    else
47        echo "ERROR: Revisit the multiarch pth_libdir fixes for pth-config!"
48        exit 1
49    fi
50fi
51if grep -e "$RPM_OPT_FLAGS" pth-config ; then
52    # Remove our extra CFLAGS from the pth-config script, since they
53    # don't belong in there.
54    sed -i -e "s!$RPM_OPT_FLAGS!!g" pth-config
55else
56    echo "ERROR: Revisit the multiarch CFLAGS fix for pth-config!"
57    exit 1
58fi
59
60# this is necessary; without it make -j fails
61make pth_p.h
62make %{?_smp_mflags}
63
64
65%check
66make test
67l=$($(pwd)/pth-config --libdir)
68%ifarch x86_64 ppc64
69    [ "$l" == "/usr/lib64" ]
70%endif
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make DESTDIR=${RPM_BUILD_ROOT} install
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87
88%files
89%defattr(-,root,root,-)
90%doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS PORTING README
91%doc SUPPORT TESTS THANKS USERS
92%{_libdir}/*.so.*
93
94%files devel
95%defattr(-,root,root,-)
96%doc HACKING
97%{_bindir}/*
98%{_includedir}/*
99%{_libdir}/*.so
100%{_mandir}/*/*
101%{_datadir}/aclocal/*
102
103
104%changelog
105* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.7-8
106- rebuild with Vine6 environment
107
108* Wed Sep 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.7-7
109- initial build for VineSeed
110
111* Sat May 31 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-7
112- Drop "|| :" from check section. It failed to build for mdomsch
113  in Rawhide today.
114
115* Fri Feb 08 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-6
116- rebuilt for GCC 4.3 as requested by Fedora Release Engineering
117
118* Sun Oct 21 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-5
119- Patch pth-config.
120  This shall fix the multiarch conflict in pth-devel (#342961).
121  It must not return -I/usr/include and -L/usr/{lib,lib64} either,
122  since these are default search paths already.
123- Replace the config.status CFLAGS sed expr with a patch.
124
125* Tue Aug 21 2007 Michael Schwendt <mschwendt@fedoraproject.org>
126- rebuilt
127
128* Thu Aug  2 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-2
129- Clarify licence (LGPLv2+).
130
131* Sat Nov 25 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-1
132- Update to 2.0.7 (very minor maintenance updates only).
133
134* Mon Aug 28 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-3
135- rebuilt
136
137* Mon May 22 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-2
138- Insert -g into CFLAGS after configure script removes it.
139- Disable configure check for obsolete sigstack(), which segfaults.
140
141* Thu Feb 16 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-1
142- Update to 2.0.6.
143
144* Fri Oct  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.5-1
145- Update to 2.0.5.
146- Don't build static archive.
147
148* Fri May 13 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-3
149- rebuilt
150
151* Thu Apr  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-2
152- rebuilt
153
154* Thu Feb 24 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.4-1
155- Update to 2.0.4.
156- Remove ancient changelog entries which even pre-date Fedora.
157
158* Tue Dec 14 2004 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.3-1
159- Update to 2.0.3, minor and common spec adjustments + LGPL, %%check,
160  use URLs for official GNU companion sites.
161
162* Thu Oct 07 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.2
163- iconv-ing spec to utf8
164
165* Wed Oct 06 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.1
166- Update to 2.0.2 and current Fedora guidelines.
167- added workaround for make -j problem
168
169* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.0.0-0.fdr.1
170- Update to 2.0.0 and current Fedora guidelines.
171- Exclude %%{_libdir}/*.la
172
173* Fri Feb  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1.fedora.1
174- First Fedora release, based on Ryan Weaver's work.
175- Move (most of) docs to main package.
176
Note: See TracBrowser for help on using the repository browser.