source: projects/specs/branches/6/p/pstoedit/pstoedit-vl.spec @ 1987

Revision 1987, 8.7 KB checked in by inagaki, 14 years ago (diff)

update: ImageMagick?, calibre, dvdauthor, inkscape, koffice, pstoedit, xine-lib, self-build-xine-lib-extras

Line 
1Name:            pstoedit
2Summary:         Translator of PostScript and PDF graphics into various vector formats
3Summary(ja):     ポストスクリプトやPDFを多種多様なベクタ形式に変換
4Version:         3.50
5Release:         3%{?_dist_release}
6
7Group:           Applications/Graphics
8License:         GPLv2
9URL:             http://www.pstoedit.net/pstoedit
10
11Source0:         http://prdownloads.sourceforge.net/pstoedit/%{name}-%{version}.tar.gz
12#Source1:         http://www.helga-glunz.homepage.t-online.de/plugins/plugins_linux_350.tgz
13
14BuildRoot:       %{_tmppath}/%{name}-%{version}-root
15BuildRequires:   libemf-devel libpng-devel gd-devel
16BuildRequires:   ImageMagick-c++-devel zlib-devel
17BuildRequires:   libtool sed
18
19Vendor:          Project Vine
20Distribution:    Vine Linux
21
22%description
23pstoedit translates PostScript and PDF graphics into other vector
24formats. Currently pstoedit can generate the following formats:
25    * Tgif .obj format (for tgif version >= 3)
26    * .fig format for xfig
27    * pdf - Adobe's Portable Document Format
28    * gnuplot format
29    * Flattened PostScript (with or without Bezier curves)
30    * DXF - CAD exchange format
31    * LWO - LightWave 3D
32    * RIB - RenderMan
33    * RPL - Real3D
34    * Java 1 or Java 2 applet
35    * Idraw format (in fact a special form of EPS that idraw can read)
36    * Tcl/Tk
37    * HPGL
38    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
39    * Windows Meta Files (WMF) (Windows 9x/NT only)
40    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
41    * OS/2 meta files (OS/2 only)
42    * PIC format for troff/groff
43    * MetaPost format for usage with TeX/LaTeX
44    * LaTeX2e picture
45    * Kontour
46    * GNU Metafile (plotutils / libplot)
47    * Sketch ( http://sketch.sourceforge.net )
48    * Mathematica
49    * via ImageMagick to any format supported by ImageMagick
50    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
51
52%description -l ja
53pstoeditはポストスクリプトやPDFを多種多様なベクタ形式に変換します。サ
54ポートしている出力ファイル形式は下記の通りです。
55    *  Tgif .obj format (for tgif version >= 3)
56    * .fig format for xfig
57    * pdf - Adobe's Portable Document Format
58    * gnuplot format
59    * Flattened PostScript (with or without Bezier curves)
60    * DXF - CAD exchange format
61    * LWO - LightWave 3D
62    * RIB - RenderMan
63    * RPL - Real3D
64    * Java 1 or Java 2 applet
65    * Idraw format (in fact a special form of EPS that idraw can read)
66    * Tcl/Tk
67    * HPGL
68    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
69    * Windows Meta Files (WMF) (Windows 9x/NT only)
70    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
71    * OS/2 meta files (OS/2 only)
72    * PIC format for troff/groff
73    * MetaPost format for usage with TeX/LaTeX
74    * LaTeX2e picture
75    * Kontour
76    * GNU Metafile (plotutils / libplot)
77    * Sketch ( http://sketch.sourceforge.net )
78    * Mathematica
79    * via ImageMagick to any format supported by ImageMagick
80    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
81
82%package        devel
83Summary:        pstoedit C Library developer.
84Summary(ja):    pstoedit 開発ライブラリ
85Group:          Development/Libraries
86URL:            http://www.pstoedit.net/pstoedit
87Requires:       pstoedit = %{version}-%{release}
88Requires:       libpng-devel libstdc++-devel zlib-devel
89
90%description devel
91pstoedit library
92
93%description -l ja devel
94pstoedit 開発ライブラリ
95
96%prep
97%setup -q
98 %{__perl} -p -i -e 's|BINDIR=/usr/local/bin||' autogen.sh
99
100%build
101./autogen.sh
102libtoolize -c -f
103
104# needed because of definitions in imagemagick headers that break with -pedantic
105sed -ie 's/-pedantic//' configure
106
107%configure  \
108        --disable-static \
109        --without-swf \
110        --with-emf \
111        --with-libemf-lib=%{_libdir} \
112        --with-libemf-include=%{_includedir}/libEMF
113 
114# don't use _smp_mflags
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%makeinstall
121#ifarch %{ix86}
122#{__install} -m 755 plugins_linux_350.so %{buildroot}%{_libdir}/%{name}
123#endif
124
125%{__mkdir_p} $RPM_BUILD_ROOT%{_mandir}/man1
126%{__install} -m 644 doc/%{name}.1  %{buildroot}%{_mandir}/man1
127
128%{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
129echo "%{_libdir}/%{name}" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/pstoedit.conf
130
131# %{__mkdir_p} %{buildroot}%{_bindir}
132# %{__install} -c config/pstoedit-config %{buildroot}%{_bindir}
133# %{__mkdir_p} %{buildroot}%{_datadir}
134# %{__install} -c -m 644 config/pstoedit.m4  %{buildroot}%{_datadir}/aclocal
135# %{__mkdir_p} %{buildroot}%{_datadir}/pstoedit/swffonts
136# %{__install} -c -m 644 misc/swffonts/default.fdb %{buildroot}%{_datadir}/pstoedit/swffonts
137# %{__install} -c -m 644 misc/latex2e.fmp %{buildroot}%{_datadir}/pstoedit
138# %{__install} -c -m 644 misc/mpost.fmp %{buildroot}%{_datadir}/pstoedit
139# %{__install} -c -m 644 misc/safer.ps %{buildroot}%{_datadir}/pstoedit
140# %{__install} -c -m 644 misc/svg.fmp %{buildroot}%{_datadir}/pstoedit
141# %{__install} -c -m 644 misc/wemf.fmp %{buildroot}%{_datadir}/pstoedit
142# %{__install} -c -m 644 misc/examplefigmap.fmp %{buildroot}%{_datadir}/pstoedit
143# ./libtool --mode=install %{__install} -c  src/libpstoedit.la  %{buildroot}%{_libdir}
144# ./libtool --mode=install %{__install} -c  src/pstoedit  %{buildroot}%{_bindir}
145# %{__mkdir_p} %{buildroot}%{_libdir}/pstoedit
146# ./libtool --mode=install %{__install} -c  src/libp2edrvstd.la   %{buildroot}%{_libdir}/pstoedit
147# ./libtool --mode=install %{__install} -c  src/libp2edrvmagick++.la  -inst-prefix %{buildroot} %{buildroot}%{_libdir}/pstoedit
148# %{__install} -c -m 644 src/pstoedit.h  %{buildroot}%{_prefix}/include/pstoedit
149# %{__install} -c -m 644 src/pstoedll.h  %{buildroot}%{_prefix}/include/pstoedit
150# %{__install} -c -m 644 src/pstoeditoutputlib.h  %{buildroot}%{_prefix}/include/pstoedit
151# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
152# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
153# %{__install} -c -m 644 src/cppcomp.h  %{buildroot}%{_prefix}/include/pstoedit
154# %{__install} -c -m 644 src/drvbase.h  %{buildroot}%{_prefix}/include/pstoedit
155# %{__install} -c -m 644 src/drvfuncs.h  %{buildroot}%{_prefix}/include/pstoedit
156# %{__install} -c -m 644 src/miscutil.h  %{buildroot}%{_prefix}/include/pstoedit
157# %{__install} -c -m 644 src/base64writer.h  %{buildroot}%{_prefix}/include/pstoedit
158# %{__install} -c -m 644 src/poptions.h  %{buildroot}%{_prefix}/include/pstoedit
159# %{__install} -c -m 644 src/ordlist.h  %{buildroot}%{_prefix}/include/pstoedit
160# %{__install} -c -m 644 src/psimage.h  %{buildroot}%{_prefix}/include/pstoedit
161#
162# %{__install} -m 775 lib/pstoedit/plugins_linux.so %{buildroot}%{_libdir}/pstoedit
163# for i in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/pstoedit/*.la
164#  do cp -p $i $i~
165#  sed s:%{buildroot}::g <$i~ >$i
166#  rm $i~
167# done
168#
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post -p /sbin/ldconfig
174
175%postun -p /sbin/ldconfig
176
177%files
178%defattr(-,root,root)
179%doc copying doc/*.htm
180%{_sysconfdir}/ld.so.conf.d/%{name}.conf
181%{_bindir}/pstoedit
182%{_libdir}/*.so.*
183%dir %{_libdir}/pstoedit
184%{_libdir}/%{name}/*.so
185%{_libdir}/%{name}/*.so.*
186%{_datadir}/%{name}
187%{_mandir}/*/*
188
189%files devel
190%defattr(-,root,root)
191%{_libdir}/*.so
192%{_includedir}/pstoedit/*
193%{_libdir}/pkgconfig/*.pc
194%{_datadir}/aclocal/*
195%exclude %{_libdir}/*.la
196%exclude %{_libdir}/pstoedit/*.la
197
198%changelog
199* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-3
200- rebuilt with ImageMagick-6.6.4.8
201
202* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-2
203- rebuilt with rpm-4.8.1 for pkg-config
204
205* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-1
206- new upstream release
207- built with new toolchain and ImageMagick-6.6.1.5
208- used ld.so.conf.d instead of ld.so.conf
209
210* Sun Jun 14 2009 Shu KONNO <owa@bg.wakwak.com> 3.45-1
211- applied new versioning policy, and spec in utf-8
212- update pstoedit to 3.45
213- added --disable-static option to %%configure
214- added --without-swf option, because of fail to compile
215
216* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.44-0vl2
217- install plugins_linux.3.42.so only on ix86 archs
218  (what should we do with the intel binary file on other archs, huh?)
219
220* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.44-0vl1
221- rebuilt for VineSeed (4.0)
222- updated to 3.44
223- fixed build dependancy
224
225* Wed Sep 28 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
226- Updated to 3.42
227
228* Tue Jan 11 2005 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
229- Updated to 3.40
230
231* Fri Sep 24 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
232- Added plugins
233- Disable emf support
234
235* Wed Sep 22 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
236- Added buildrequires
237
238* Thu Oct  2 2003  Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
239- initial package
Note: See TracBrowser for help on using the repository browser.