source: projects/specs/branches/6/p/proftpd/proftpd-vl.spec @ 3687

Revision 3687, 13.6 KB checked in by iwamoto, 13 years ago (diff)

proftpd: update 1.3.3e

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.3e
6%define origversion     1.3.3e
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 1%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.3e-iconv.patch
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37# nothing..
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: pam-devel, openldap-devel, openssl-devel
41BuildRequires: ncurses-devel, libcap-devel, libacl-devel
42BuildRequires: e2fsprogs-devel
43Requires: pam > 0.59
44Obsoletes: wu-ftpd, anonftp
45Provides: ftpserver
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51ProFTPd is an enhanced FTP server with a focus toward simplicity,
52security, and ease of configuration.  It features a very Apache-like
53configuration syntax, and a highly customizable server infrastructure,
54including support for multiple 'virtual' FTP servers, anonymous FTP,
55and permission-based directory visibility.
56
57%description -l ja
58ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
59FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
60anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
61高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
62
63%prep
64%setup -q -n %{name}-%{tarballversion}
65find . -type d -name CVS | xargs -r rm -frv
66
67# upstream fixes
68
69## patches from mdk
70# use system-auth instaed of pam_pwdb
71%patch201 -p1
72
73# iconv patch (CharsetLocal/CharsetRemote)
74%patch300 -p1
75
76# fix build on recent kernel headers
77# %patch400 -p0
78
79# security fixes
80
81%build
82# Disable stripping in order to get useful debuginfo packages
83%{__perl} -pi -e 's|"-s"|""|g' configure
84
85%configure \
86    --libexecdir="%{_libexecdir}/proftpd" \
87    --localstatedir="%{_var}/run/proftpd" \
88    --enable-ctrls \
89    --enable-facl \
90    --enable-dso \
91    --enable-ipv6 \
92    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
93mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
94    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
95
96# It seems that with _smp_mflags -lsupp tries to get linked before being built
97# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
98%{__make}
99
100
101%install
102%{__rm} -rf %{buildroot}
103%{__make} install DESTDIR=%{buildroot} \
104    rundir="%{_var}/run/proftpd" \
105    INSTALL_USER=`id -un` \
106    INSTALL_GROUP=`id -gn`
107
108# auth
109mkdir -p %{buildroot}%{_sysconfdir}/pam.d
110%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
111
112# logrotate
113mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
114%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
115
116# init.d
117%{__install} -D -p -m 0755 %{SOURCE3} \
118    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
119
120%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
121%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
122%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
123
124touch %{buildroot}%{_sysconfdir}/ftpusers
125
126rm contrib/README.* || :
127# eliminate executable bit in %doc
128find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
129
130# remove .{la,a}
131rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
132
133# remove development files (headers and pkgconfig file)
134# who need these files?
135rm -rf %{buildroot}%{_includedir}/proftpd
136rm -rf %{buildroot}%{_libdir}/pkgconfig
137
138%preun
139if [ -d %{_rundir} ] ; then
140        rm -rf %{_rundir}/*
141fi
142
143if [ $1 = 0 ] ; then
144        /sbin/chkconfig --del proftpd
145fi
146
147%postun
148if [ $1 -ge 1 ]; then
149    /sbin/service proftpd condrestart
150fi
151
152%post
153/sbin/chkconfig --add proftpd
154
155
156%clean
157rm -rf %{buildroot}
158
159%files
160%defattr(-,root,root)
161%doc COPYING CREDITS ChangeLog INSTALL NEWS
162%doc README.{LDAP,PAM,modules} doc/*
163%doc contrib/README contrib/xferstats.holger-preiss
164%doc sample-configurations/
165%{_sbindir}/*
166%{_bindir}/*
167%{_mandir}/*/*
168%{_var}/ftp/welcome.msg
169%dir %{_libexecdir}/proftpd/
170%{_libexecdir}/proftpd/mod_*
171%dir %{_rundir}
172%dir %{_var}/ftp
173%config %{_sysconfdir}/rc.d/init.d/proftpd
174%config(noreplace) %{_sysconfdir}/pam.d/ftp
175%config(noreplace) %{_sysconfdir}/proftpd.conf
176%config(noreplace) %{_sysconfdir}/ftpusers
177%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
178
179
180%changelog
181* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
182- new upstream release
183- update patch300 to fit new version
184- drop patch1000 (is included in new release)
185- add BR: e2fsprogs-devel
186
187* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
188- rebuild with openssl-1.0.0c
189
190* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
191- new upstream release
192- add patch1000 for CVE-2010-4221 (TELNET_IAC)
193- add BRs: ncurses-devel, libcap-devel, libacl-devel
194
195* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
196- new upstream release with security fix (CVE-2009-3555)
197
198* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
199- new upstream release with security fix (NULL char in X.509 certificate)
200- add chkconfig --add in post script
201
202* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
203- remove .{la,a}
204- remove headers and pkgconfig file
205
206* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
207- update Source1 (sample config file for vine)
208  set default char set to UTF-8
209
210* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
211- new upstream release
212
213* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
214- rebuild with openldap-2.4.11
215
216* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
217- built with openssl-0.9.8k
218
219* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
220- new upstream release
221- add configure option to activate new modules
222- drop patch400
223
224* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
225- built with openssl-0.9.8j
226
227* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
228- built with openssl-0.9.8i
229
230* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
231- add Patch400 to fix build failure at least on i386
232- spec in UTF-8
233
234* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
235- built with openssl-0.9.8h
236
237* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
238- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
239
240* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
241- new upstream release
242- drop old patches which are included in new release
243- update patch201, 300
244- build under new versioning policy
245
246* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
247- new upstream release
248- built with openssl098
249- drop old (for 1.2.10) patches
250- Patch100-150 from FC8 package
251- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
252- update patch300 for 1.3.0
253- change configure option refer to FC8
254- add process reboot with message output when package is upgraded
255- docfiles list update
256- fix changelog ver number typo
257
258* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
259- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
260  (<WISHES:15>)
261- add Vendor/Distribution tag
262- add patch104 for fix pr_ctrls_recv_request issue
263- add patch103 for fix CVE-2006-6170
264- add patch102 for fix CVE-2006-5815
265- add patch101 for fix CVE-2006-6171
266
267* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
268- rebuilt with openldap-2.3.27-0vl
269
270* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
271- rebuilt with openldap-2.3.24-0vl1
272
273* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
274- add patch300 for iconv patch
275
276* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
277- enable mod_ldap
278- add BuildRequires: openldap-devel, openssl-devel
279- add Patch200 from MDK to support ldap
280- add Patch201 from MDK to use system-auth instead of pam_pwdb
281  (pam_pwdb is now obsolete, and will be removed in the future pam version)
282
283* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
284- 1.2.10-0vl1.1
285- add patch100 for fix CAN-2005-2390
286
287* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
288- new upstream release
289
290* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
291- new upstream release (1.2.10rc3)
292- build for Vine Linux 3.0
293
294* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
295- new upstream release
296- fix security issue: http://secunia.com/advisories/11527/
297
298* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
299- new upstream release
300
301* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
302- new upstream release
303- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
304
305* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
306- new upstream release
307
308* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
309- new upstream release 1.2.7
310- add logrotate config file.
311- move ftp home directory from /home/ftp to /var/ftp
312
313* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
314- new upstream release 1.2.6
315
316* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
317- new upstream release 1.2.5 (stable release version)
318
319* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
320- new upstream release 1.2.5-rc3
321
322* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
323- eliminate executable bit in %doc (requierment for /usr/bin/perl)
324- put files in sample-configurations/ to the according directory
325- remove unnecessary README.* files
326
327* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
328- updated to 1.2.5rc1 for problems in file globbing
329
330* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
331- 1.2.4-0vl1
332
333* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
334- 1.2.3-0vl1
335
336* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
337- 1.2.2-0vl1: update to 1.2.2 release
338- added more documents
339
340* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
341- update to 1.2.2rc3
342- use macros
343
344* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
345- 1.2.1-0vl3
346- rebuilt for VineSeed
347
348* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
349- update to 1.2.1
350
351* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
352- build for VineSeed
353
354* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
355- update to 1.2.0
356- set Epoch 1 to update from pre* and rc* version
357 
358* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
359- 1.2.0rc3-0vl3
360- removed PreReq and postun about /etc/ftpusers stuff
361
362* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
363- remove setup of /etc/ftpusers in %%pre script
364- add ftpusers.vine insted of the %%pre script
365- remove contrib/README.* frpm %%files
366- add BuildRequires: pam-devel
367
368* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
369- rebuild for VineSeed
370
371* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
372- update to 1.2.0rc3
373- add 'TimesGMT FALSE' in default configuration file
374- build on Vine 2.1
375
376* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
377- modified pre script to make it run by bash2 and added PreReq
378- remove /etc/ftpusers after uninstall
379
380* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
381- 1.2.0rc2-0vl8
382- rebuilt on VineSeed
383
384* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
385- remove patch from CVS to avoid 'after 5min data brake'
386- add passive patch insted of abobe CVS patch
387- revival contribute's proftpd.init.d
388
389* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
390- fixed %pre script and remove /etc/ftpusers from files
391- modify Japanese summary and descriptions
392
393* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
394- actually fixed to make the package relocatable.
395- non-root build failure by broken %prein, which should be %pre.
396- dont include CVS directory in doc
397- add %config /etc/rc.d/init.d/proftpd
398
399* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
400- correct config directive of the init.d script
401
402* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
403- adopt current patch from CVS to avoid the 'put on passive mode' probrem
404
405* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
406- 1.2.0rc2-0vl1
407- obsoletes anonftp
408- do not chkconfig --add in %post
409- requires: pam
410- added proftpd.vine.conf
411
412* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
413- libtoolize for alpha
414
415* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
416- [1.2.0rc2]
417
418* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
419- repackaging for VineLinux
420
421* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
422- Multi package creation.
423  Created core, standalone, inetd (&doc) package creations.
424  Added startup script for init.d
425  Need to make the "standalone & inetd" packages being created as "noarch"
426- Added URL.
427- Added prefix to make the package relocatable.
428
429* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
430- Corrected inetd.conf line addition/change logic.
431
432* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
433- Initial import of spec.
434
Note: See TracBrowser for help on using the repository browser.