source: projects/specs/branches/6/p/preload/preload-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           preload
2Version:        0.6.4
3Release:        4%{?_dist_release}
4Summary:        an adaptive readahead daemon
5Summary(ja):    適応的先読みデーモン
6Group:          Applications/System
7License:        GPLv2+
8URL:            http://preload.sf.net/
9Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10
11#Patch0:                preload-0.6-start-late.patch
12
13Patch0: preload.init.in.patch
14#This patch prefered to http://sourceforge.net/tracker/index.php?func=detail&aid=2183212&group_id=143398&atid=755420
15Patch1: preload-conf.patch
16#This patch from http://preload.svn.sourceforge.net/viewvc/preload/trunk/src/cmdline.c?revision=122
17#Patch2: fix_segfault.patch
18#This patch from Mandriva
19#Patch3: preload-0.6.3-glib214.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22BuildRequires:  basesystem, glib2-devel
23Requires:       basesystem, logrotate
24Requires(post): /sbin/chkconfig
25Requires(post): /sbin/service
26Requires(preun): /sbin/chkconfig
27Requires(preun): /sbin/service
28Requires(postun): /sbin/service
29
30%description
31preload monitors applications that users run, and by analyzing this data,
32predicts what applications users might run, and fetches those binaries and
33their dependencies into memory for faster startup times.
34
35%description -l ja
36preload は起動中のアプリケーションを監視し、監視したデータを分析することで、
37度のアプリケーションユーザが起動されるかを予想し、バイナリと依存する
38ライブラリをメモリに取り込み、起動時間を高速にします。
39
40%prep
41%setup -q
42%patch0 -p1
43%patch1 -p1
44#%patch2 -p1
45#%patch3 -p1
46
47%build
48%configure
49%{__make}
50
51
52%install
53%{__rm} -rf $RPM_BUILD_ROOT
54%{__make} install DESTDIR=$RPM_BUILD_ROOT
55
56
57%clean
58%{__rm} -rf $RPM_BUILD_ROOT
59
60%post
61/sbin/service preload restart >/dev/null 2>&1
62/sbin/chkconfig --add preload
63/sbin/chkconfig preload on
64
65%preun
66if [ $1 = 0 ]; then
67    /sbin/service preload stop >/dev/null 2>&1
68    /sbin/chkconfig --del preload
69fi
70
71%postun
72if [ "$1" -ge "1" ]; then
73    /sbin/service preload condrestart >/dev/null 2>&1 || :
74fi
75
76
77%files
78%defattr(-,root,root, -)
79%doc README AUTHORS COPYING ChangeLog TODO THANKS NEWS
80%{_sbindir}/preload
81%{_datadir}/man/man8/preload.8.gz
82%{_sysconfdir}/rc.d/init.d/preload
83%config(noreplace) %{_sysconfdir}/preload.conf
84%config(noreplace) %{_sysconfdir}/sysconfig/preload
85%config(noreplace) %{_sysconfdir}/logrotate.d/preload
86%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/preload.log
87%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/lib/preload/preload.state
88%attr(0755,root,root) %dir %{_localstatedir}/lib/preload
89
90
91%changelog
92* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-4
93- rebuilt with gcc-4.4.3-3 on ppc
94
95* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-3
96- rebuilt with rpm-4.8.0-3 (on ppc)
97
98* Wed Feb  3 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-2
99- rebuilt with new toolchain
100
101* Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
102- new upstream release
103- dropped Patch2,3 (merged)
104
105* Thu Mar 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-4
106- added patch3 (import from Mandriva 2009.1)
107
108* Mon Dec 22 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-3
109- changed patch0 (Prefered to Mandriva 2009.0 package in preload-0.6.3-prcsys.patch)
110
111* Mon Dec 8 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-2
112- Removed preload-0.6-start-late.patch
113- Added patch0, patch1, patch2
114  Patch0: start preload daemon later, changed default-start
115  Patch1: changed mapprefix&exeprefix section
116  added /opt, for some applicaton (ex. Adobe Reader, OpenOffice.org)
117  Patch2: fix segfault src/cmdline.c
118
119* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
120- new upstream release
121- drop all patches, they are all obsolete by upstream.
122- add Patch0 to start preload daemon lator. (use readahead daemon for bootup)
123
124* Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
125- applied new versioning policy, spec in utf-8
126
127* Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vl1
128- initial build for VineSeed based on Fedora package
129
130# * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp0
131# - rebuild for Vine Linux 4.2
132#
133# * Wed Mar 5 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp1
134# - initial build for VineSeed based on Fedora package
135
136* Wed Jan 16 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-5
137- Removed auto start from init
138- Added all the CVS patches prior to next release
139
140* Sun Jan 6 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-4
141- Removed debian patch and added patches from upstream instead
142- Patches fix 64 bit, ionice, sysconfig and loading.
143
144* Fri Nov 9 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-3
145- Used Debian Patch it consists of:
146- Close the file descriptor when writing state to a file in src/state.c,
147- Parse the dev field in /proc/%%d/maps as hexadecimal, not as unsigned
148  integer.  Thanks to Johan Kiviniemi for the patch.
149- Sort the readahead file list by device, block and inode and not file
150  path to reduce seeking.  Adapted by Johan from a patch for readahead
151  by Scott James Remnant.
152- Added my patch to verbosity to 1 due to 30 second log writing
153 
154* Thu Nov 8 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-2
155- Fixed config lines
156- Fixed source lines
157- Added Requires: Logrotate
158- Default preload sequence is stopped
159- %{?_smp_mflags} does not work
160
161* Sat Oct 16 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-1
162- Creation from start
163
164### end of file
Note: See TracBrowser for help on using the repository browser.