source: projects/specs/branches/6/p/polkit/polkit-vl.spec @ 7819

Revision 7819, 8.0 KB checked in by kudoh, 11 years ago (diff)
Line 
1Summary: PolicyKit Authorization Framework
2Summary(ja): PolicyKit 認証フレームワーク
3Name: polkit
4Version: 0.99
5Release: 2%{?_dist_release}
6License: LGPLv2+
7URL: http://www.freedesktop.org/wiki/Software/PolicyKit
8Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
9
10Patch100: polkit_CVE-2013-4288.patch
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13Group: System Environment/Libraries
14BuildRequires: glib2-devel
15BuildRequires: expat-devel
16BuildRequires: pam-devel
17BuildRequires: eggdbus-devel >= 0.6
18BuildRequires: gtk-doc
19BuildRequires: intltool
20BuildRequires: gobject-introspection-devel
21
22Requires: ConsoleKit
23Requires: dbus
24
25#Obsoletes: PolicyKit <= 0.10
26#Provides: PolicyKit = 0.11
27
28%description
29PolicyKit is a toolkit for defining and handling authorizations.
30It is used for allowing unprivileged processes to speak to privileged
31processes.
32
33%package devel
34Summary: Development files for PolicyKit
35Summary(ja): PolicyKit の開発用ファイル
36Group: Development/Libraries
37Requires: %name = %{version}-%{release}
38Requires: %name-docs = %{version}-%{release}
39Requires: pkgconfig
40Requires: glib2-devel
41#Obsoletes: PolicyKit-devel <= 0.10
42#Provides: PolicyKit-devel = 0.11
43
44%description devel
45Development files for PolicyKit.
46
47%package docs
48Summary: Development documentation for PolicyKit
49Summary(ja): PolicyKit の開発用ドキュメント
50Group: Development/Libraries
51Requires: %name-devel = %{version}-%{release}
52Requires: gtk-doc
53#Obsoletes: PolicyKit-docs <= 0.10
54#Provides: PolicyKit-docs = 0.11
55
56%description docs
57Development documentation for PolicyKit.
58
59%package desktop-policy
60Summary: Roles and default policy for desktop usage
61Summary(ja): デスクトップ用途のロールとデフォルトポリシー
62Group: Development/Libraries
63#Requires: %name = %{version}-%{release}
64Requires(pre): /usr/sbin/groupadd
65Requires(preun): /usr/sbin/groupdel
66
67%description desktop-policy
68Roles and default policy for desktop usage.
69
70%prep
71%setup -q
72%patch100 -p1 -b .CVE-2013-4288
73
74%build
75%configure --enable-gtk-doc --disable-static --libexecdir=%{_libexecdir}/polkit-1 --enable-introspection --enable-examples
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
83rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
84
85%find_lang polkit-1
86
87###
88### BEGIN DESKTOP POLICY CONFIGURATION ###
89###
90
91cat > $RPM_BUILD_ROOT%{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf << EOF
92# This allows users in the desktop_admin_r group to authenticate as
93# the administrator.
94#
95# DO NOT EDIT THIS FILE, it will be overwritten on update.
96
97[Configuration]
98AdminIdentities=unix-group:desktop_admin_r
99EOF
100
101cat > $RPM_BUILD_ROOT%{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla << EOF
102# Authorizations/policy for the desktop_admin_r and desktop_user_r groups.
103#
104# DO NOT EDIT THIS FILE, it will be overwritten on update.
105
106# Allow "standard users" to do some things without being interrupted by
107# password dialogs (TODO: not complete)
108#
109[Desktop User Permissions]
110Identity=unix-group:desktop_user_r
111Action=org.gnome.clockapplet.mechanism.settimezone
112ResultAny=no
113ResultInactive=no
114ResultActive=yes
115
116# Allow "administrative users" to do a lot of things without being interrupted by
117# password dialogs (TODO: not complete)
118#
119[Desktop Administrator Permissions]
120Identity=unix-group:desktop_admin_r
121Action=org.gnome.clockapplet.mechanism.*;org.freedesktop.devicekit.disks.*;org.freedesktop.RealtimeKit1.*
122ResultAny=no
123ResultInactive=no
124ResultActive=yes
125
126EOF
127
128###
129### END DESKTOP POLICY CONFIGURATION
130###
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post -p /sbin/ldconfig
136
137%postun -p /sbin/ldconfig
138
139%pre desktop-policy
140/usr/sbin/groupadd -r desktop_admin_r 2> /dev/null || :
141/usr/sbin/groupadd -r desktop_user_r 2> /dev/null || :
142
143%files desktop-policy
144%{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf
145%{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla
146
147%files -f polkit-1.lang
148%defattr(-,root,root,-)
149%doc COPYING
150%{_libdir}/lib*.so.*
151%dir %{_libdir}/polkit-1
152%dir %{_libdir}/polkit-1/extensions
153%{_libdir}/polkit-1/extensions/*.so
154%{_datadir}/man/man1/*
155%{_datadir}/man/man8/*
156%{_datadir}/dbus-1/system-services/*
157%dir %{_datadir}/polkit-1/
158%dir %{_datadir}/polkit-1/actions
159%{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
160%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
161%{_sysconfdir}/pam.d/polkit-1
162%{_sysconfdir}/polkit-1
163%{_bindir}/pkaction
164%{_bindir}/pkcheck
165%{_libexecdir}/polkit-1/polkitd
166%{_libdir}/girepository-1.0/*.typelib
167
168# see upstream docs for why these permissions are necessary
169%attr(4755,root,root) %{_bindir}/pkexec
170%attr(4755,root,root) %{_libexecdir}/polkit-1/polkit-agent-helper-1
171
172%attr(0700,root,root) %dir %{_localstatedir}/lib/polkit-1/
173%dir %{_localstatedir}/lib/polkit-1/localauthority
174%dir %{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d
175%dir %{_localstatedir}/lib/polkit-1/localauthority/20-org.d
176%dir %{_localstatedir}/lib/polkit-1/localauthority/30-site.d
177%dir %{_localstatedir}/lib/polkit-1/localauthority/50-local.d
178%dir %{_localstatedir}/lib/polkit-1/localauthority/90-mandatory.d
179
180%files devel
181%defattr(-,root,root,-)
182%{_libdir}/lib*.so
183%{_libdir}/pkgconfig/*.pc
184%{_datadir}/gir-1.0/*.gir
185%{_includedir}/*
186%{_bindir}/pk-example-frobnicate
187%{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
188
189%files docs
190%defattr(-,root,root,-)
191%{_datadir}/gtk-doc/html/*
192
193%changelog
194* Sat Sep 21 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.99-2
195- added Patch100 to fix CVE-2013-4288
196
197* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
198- new upstream release
199
200* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
201- build with rpm-4.8.1-1 for pkg-config file
202
203* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
204- update to 0.96
205- BR: eggdbus-devel >= 0.6
206
207* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
208- remove Obsoletes:/Provides: PolicyKit*
209
210* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
211- initial build for Vine Linux
212
213* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
214- Refine how Obsolete: is used and also add Provides: (thanks Jesse
215  Keating and nim-nim)
216
217* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
218- Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
219- Obsolete old PolicyKit packages
220
221* Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
222- Update to git snapshot
223- Drop upstreamed patches
224- Turn on GObject introspection
225- Don't delete desktop_admin_r and desktop_user_r groups when
226  uninstalling polkit-desktop-policy
227
228* Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
229- Add some patches from git master
230- Sort pkaction(1) output
231- Bug 23867 – UnixProcess vs. SystemBusName aliasing
232
233* Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
234- Add desktop_admin_r and desktop_user_r groups along with a first cut
235  of default authorizations for users in these groups.
236
237* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
238- Disable GObject Introspection for now as it breaks the build
239
240* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
241- Update to upstream release 0.94
242
243* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
245
246* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
247- Rebuild
248
249* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
250- Update to 0.93
251
252* Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
253- Don't make docs noarch (I *heart* multilib)
254- Change license to LGPLv2+
255
256* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
257- Rebuild
258
259* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
260- Update to 0.92 release
261
262* Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
263- Update to 0.92 snapshot
264
265* Mon Feb  9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
266- Initial spec file.
Note: See TracBrowser for help on using the repository browser.