source: projects/specs/branches/6/p/po-mode/po-mode-vl.spec @ 3633

Revision 3633, 7.4 KB checked in by iwaim, 13 years ago (diff)

po-mode-0.18.1.1-1

Line 
1%define origname       po-mode
2
3Summary: Emacs Lisp for editing po file of gettext
4Summary(ja): gettextの po ファイルを編集するためのEmacs Lisp
5Name: po-mode
6Version: 0.18.1.1
7Release: 1%{?_dist_release}
8License: GPLv3 and LGPLv2+
9Group: Applications/Editors/Emacs
10Source: ftp://ftp.gnu.org/gnu/gettext/gettext-%{version}.tar.gz
11URL: http://www.gnu.org/software/gettext/
12Source1: po-mode-init.el
13Source3: %{origname}-install.sh
14Source4: %{origname}-remove.sh
15Source5: vine-default-%{origname}.el
16Requires(post): emacsen, emacsen-common >= 0.1
17Requires: emacsen
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19BuildArch: noarch
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Emacs Lisp for editing po file of gettext
27
28%description -l ja
29gettext の po ファイルを編集するための Emacs Lisp です.
30
31%prep
32%setup -q -n gettext-%{version}
33
34%build
35
36%install
37[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
38[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
39
40mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
41mkdir -p %{buildroot}%{emacsen_pkgdir}/install
42mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
43
44#
45# install el files
46#
47
48pushd gettext-tools/misc
49cp -p *.el %{SOURCE1} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
50popd
51
52#
53# install script (bytecompile el and install elc , remove)
54#
55
56%_installemacsenscript %{origname} %{SOURCE3}
57
58%_removeemacsenscript  %{origname} %{SOURCE4}
59
60
61%clean
62[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
63
64
65%post
66if [ "$1" = 2 ]; then
67  %_emacsenPackageRemove %{origname}
68
69fi
70
71%_addemacsenlist %{origname}
72
73%_emacsenPackageInstall %{origname}
74
75
76%preun
77if [ "$1" = 0 ]; then
78  %_emacsenPackageRemove %{origname}
79
80  %_removeemacsenlist %{origname}
81
82fi
83
84
85%files
86%defattr(-,root,root,-)
87%doc AUTHORS COPYING THANKS NEWS
88%doc gettext-tools/misc/ChangeLog
89%{_datadir}/emacs/site-lisp/%{origname}
90%{emacsen_pkgdir}/install/%{origname}
91%{emacsen_pkgdir}/remove/%{origname}
92
93
94%changelog
95* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 0.18.1.1-1
96- new upstream release
97- drop using forward-line patch (Patch0): upstream fixed
98- add Requires: emacsen
99
100* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
101- split from gettext package: [VineSeed:20076]
102- add Packager
103- replace Prereq to Requires(post)
104- add using forward-line patch (Patch0): <BTS:VineLinux:934>
105
106* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
107- correct some output messages on po-mode-install.sh
108- use %%emacsen_pkgdir
109
110* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
111- we better not to use BuildConflicts very often :-P
112  instead we pass --disable-java to configure here
113- add --enable-shared --disable-static --without-included-gettext to configure
114- remove .la files
115- add -devel and --libs subpackages
116
117* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
118- apply vine-default
119  - update po-mode-init.el (Source1)
120  - update po-mode-install.sh (Source3)
121  - update po-mode-remove.sh (Source4)
122  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
123- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
124
125* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
126- new upstream release
127
128* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
129- applied new versioning policy, spec in utf-8
130
131* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
132- changelog update missing
133
134* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
135- new upstream release
136
137* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
138- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
139
140* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
141- add BuildConflicts: libgcj34-devel not to depend on libgcj34
142
143* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
144- add BuildConflicts: libgcj-devel not to depend on libgcj
145- add BuildRequires: emacsen (if emacsen_pkg is enabled)
146- remove unneeded files at the %%install
147
148* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
149- rebuilt without libgcj package
150
151* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
152- modified emacsen-common path
153
154* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
155- new upstream release
156- updated Source3
157- added --disable-csharp
158
159* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
160- remove dependency to libgcj
161
162* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
163- new upstream release
164
165* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
166- build without libgcj package
167- create po-mode package for Emacsen
168
169* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
170- based on Redhat Rawhide 0.12.1-1
171- dropped all patches (Rawhide does so)
172- Source100(ja.po) is much older than source, dropped
173- s/Copyright/License/
174
175* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
176- new upstream release
177
178* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
179- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
180
181* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
182- sync with RH6.2
183
184* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
185- minor configure tweaks for ia64
186
187* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
188- add --comments to msghack
189
190* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
191- fix bug #9240 - gettextize has the right aclocal patch
192
193* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
194- add the --diff and --dummy options
195
196* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
197- add the --missing option to msghack
198
199* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
200- updated msghack not to merge in fuzzies in the master catalogs
201
202* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
203- update ja.po
204
205* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
206- use message.c.diff-2
207
208* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
209- updated msghack to understand --append
210
211* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
212- updated msghack to correctly deal with sorting files
213
214* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
215- added multibyte patch for msgmerge
216
217* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
218- ja locale support from JaPO Project
219
220* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
221- msghack updates
222
223* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
224- auto rebuild in the new build environment (release 8)
225
226* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
227- added patch for misc hacks to facilitate rpm translations
228
229* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
230- patch to allow to build on ARM
231
232* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
233- add Emacs po-mode.el files.
234
235* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
236- include the aclocal support files
237
238* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
239- remove devel package (functionality is in glibc)
240
241* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
242- update to 0.10.35.
243
244* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
245- add gettextize.
246- create devel package for libintl.a and libgettext.h.
247
248* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
249- translations modified for de, fr, tr
250
251* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
252- added info handling
253- added misc-patch (skip emacs-lisp modofications)
254
255* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
256- removed locale.aliases as we get it from glibc now
257- uses a buildroot
258
259* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
260- Built against glibc
Note: See TracBrowser for help on using the repository browser.