source: projects/specs/branches/6/p/playmidi/playmidi-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A MIDI sound file player.
2Summary(ja): MIDI 音源ファイルプレーヤ
3Name: playmidi
4Version: 2.4
5Release: 14%{?_dist_release}
6Source: ftp://ftp.linpeople.org/pub/People/nathan/playmidi-2.4.tar.gz
7Source2: awe_voice.h
8License: GPL2
9Group: Applications/Multimedia
10Patch0: playmidi-2.3-hertz.patch
11Patch1: playmidi-2.3-awe2.patch
12Patch2: playmidi-2.4-make.patch
13Patch3: playmidi-2.4-midimap.patch
14
15BuildRequires: XOrg-devel ncurses-devel
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19Playmidi plays MIDI (Musicial Instrument Digital Interface) sound
20files through a sound card synthesizer.  This package includes basic
21drum samples for use with simple FM synthesizers.
22
23Install playmidi if you want to play MIDI files using your computer's
24sound card.
25#'
26
27%package X11
28Summary: An X Window System Interface based MIDI sound file player.
29Requires: playmidi = %{version}
30Requires: XOrg-libs
31Group: Applications/Multimedia
32
33%description X11
34Playmidi-X11 provides an X Window System interface for playing MIDI
35(Musical Instrument Digital Interface) sound files through a sound
36card synthesizer.  This package includes basic drum samples for use
37with simple FM synthesizers.
38
39Install playmidi-X11 if you want to use an X interface to play MIDI
40sound files using your computer's sound card.
41#'
42
43%prep
44%setup -q
45cp $RPM_SOURCE_DIR/awe_voice.h .
46%patch0 -p1 -b .consthertz
47%patch1 -p1 -b .awe2
48%patch2 -p1 -b .make
49%patch3 -p1 -b .midimap
50
51
52%build
53PATH=.:$PATH
54%ifarch x86_64
55make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" \
56        LIBX11="-L%{_libdir} -lXaw -lXmu -lXt -lX11 -lXext -lSM -lICE" \
57        playmidi xplaymidi <<EOF
582
59EOF
60%else
61make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" playmidi xplaymidi <<EOF
622
63EOF
64%endif
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69mkdir -p $RPM_BUILD_ROOT/etc/midi
70mkdir -p $RPM_BUILD_ROOT%{_bindir}
71mkdir -p $RPM_BUILD_ROOT%{_libdir}
72mkdir -p $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
73mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
74
75install -s -m 755 playmidi xplaymidi $RPM_BUILD_ROOT%{_bindir}
76install -m 644 XPlaymidi.ad $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/XPlaymidi
77install -m 644 playmidi.1 $RPM_BUILD_ROOT%{_mandir}/man1
78
79mkdir -p $RPM_BUILD_ROOT/etc/midi
80for n in std.o3 drums.o3 std.sb drums.sb
81do
82        install -m 644 $n $RPM_BUILD_ROOT/etc/midi/$n
83done
84
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%files
91%defattr(-,root,root)
92%doc BUGS COPYING QuickStart README* *.mid techref/
93%{_bindir}/playmidi
94%config /etc/midi/std.o3
95%config /etc/midi/std.sb
96%config /etc/midi/drums.o3
97%config /etc/midi/drums.sb
98%{_mandir}/man1/playmidi.*
99
100%files X11
101%defattr(-,root,root)
102%{_bindir}/xplaymidi
103%config %{_datadir}/X11/app-defaults/XPlaymidi
104
105
106%changelog
107* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.4-14vl5
108- rebuild with libXaw.so.7 (libXaw-1.0.5)
109
110* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.4-13vl5
111- applied new versioning policy, spec in utf-8
112- modified X11 paths
113
114* Fri Dec 28 2007 Shu KONNO <owa@bg.wakwak.com> - 2.4-12vl4
115- added option LIBX11 to make (for x86_64)
116
117* Fri Jan 28 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4-12vl3
118- rebuild with new toolchains
119- added BuildRequires: XOrg-devel ncurses-devel
120- added Requires: XOrg-libs to X11 subpackage
121- s/Copyright/License/
122
123* Fri Nov 16 2001 Jun Nishii <jun@vinelinux.org>
124- 2.4-12vl2
125- added some files in %doc
126
127* Mon Dec 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
128- 2.4-12vl1
129- based on 2.4-12 on rawhide
130- rebuild for Vine Linux with ncurses5
131
132* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
133- automatic rebuild
134
135* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
136- rebuild, FHS stuff
137
138* Mon Mar  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
139- rebuild with current ncurses
140
141* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
142- handle compressed man pages
143
144* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
145- don't ship splaymidi
146
147* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
148- auto rebuild in the new build environment (release 7)
149
150* Tue Feb 23 1999 Bill Nottingham <notting@redhat.com>
151- wmconfig goes away
152
153* Mon Dec 28 1998 Bill Nottingham <notting@redhat.com>
154- build against glibc-2.1
155
156* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
157- oops. We broke FM synth. Fixed.
158
159* Sat Oct 10 1998 Cristian Gafton <gafton@redhat.com>
160- strip binaries
161- updated to version 2.4
162
163* Wed Sep  9 1998 Bill Nottingham <notting@redhat.com>
164- added AWE32 support
165
166* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
167- build root
168- sound font data in /etc/midi
169
170* Thu May 07 1998 Prospector System <bugs@redhat.com>
171- translations modified for de, fr, tr
172
173* Wed Apr 15 1998 Erik Troan <ewt@redhat.com>
174- built against new ncurses
175
176* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
177- added wmconfig entries
178
179* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
180- built against glibc
Note: See TracBrowser for help on using the repository browser.