source: projects/specs/branches/6/p/plan/plan-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 1.8.7
2%define rel 0vl5
3
4Summary: an X/Motif calendar and day planner
5Summary(ja): X/Motif ¤òÍѤ¤¤¿¹âµ¡Ç½¥¹¥±¥¸¥å¡¼¥é
6
7Name:  plan
8Version: %{ver}
9Release: %{rel}
10
11Source:  ftp://ftp.fu-berlin.de/pub/unix/graphics/plan/plan-%{ver}.tar.gz
12# vine sources
13Source1: Plan.vine.ad
14Source2: holiday_japan_EUC
15Source3: plan-1.8.3.lang.japanese
16# from vine-users:023414
17Source4: plan_calEUC.ps
18Source5: netplan.boot
19Source6: plan.sh
20Source7: netplangrpadd.sh
21Source8: plan.README.vine
22
23# vine patches
24Patch:   plan-1.8.7-jp.vine.patch
25#jp patch is merged with http://cgi.shikoku.ne.jp/~fun/srpms.html
26Patch1:  plan-1.8.7-jp.patch
27Patch2:  plan-1.8.7-netplan.patch
28Patch3: plan-1.8.4-makefile.patch
29URL:    http://www.IN-Berlin.DE/User/bitrot/plan.html
30License: distributable
31Group: Applications/Productivity
32Buildroot: %{_tmppath}/%{name}-root
33BuildPrereq: openMotif-devel, byacc, flex
34Requires: openMotif
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%description
40Plan is a schedule planner based on X/Motif. It also works with
41lesstif instead of Motif. It displays a month calendar similar to
42xcal, but every day box is large enough to show appointments in small
43print. By pressing on a day box, the appointments for that day can
44be listed and edited.
45
46%description -l ja
47Plan¤ÏX/Motif¤òÍѤ¤¤¿¹âµ¡Ç½¥¹¥±¥¸¥å¡¼¥é¤Ç¤¹¡¥·îɽ¼¨¡¤½µÉ½¼¨¡¤°ìÆüɽ¼¨Åù¤¬
48¤Ç¤­¡¤¥Í¥Ã¥È¥ï¡¼¥¯¤ò²ð¤·¤¿¥°¥ë¡¼¥×¤Ç¤ÎÍøÍѤâ¤Ç¤­¤Þ¤¹¡¥Apple Newton PDA ¤ä
49PalmPilot PDA ¤È¤Î¥Õ¥¡¥¤¥ë¸ò´¹¤â¤Ç¤­¤Þ¤¹¡¥ÍøÍÑ¤Ë¤Ï openMotif ¤¬É¬ÍפǤ¹¡£
50
51netplan ¤òÍøÍѤ¹¤ë¤È¤­¤Ë¤Ï¡¢netplan.dir ¤È¤·¤Æ /home/netplan ¤òÍøÍѤ¹¤ë
52¤è¤¦¤ËÀßÄꤷ¤Æ¤¢¤ê¤Þ¤¹¡£
53
54%prep
55rm -rf %{buildroot}
56%setup -n plan-%{ver}
57%patch -p1
58
59%patch1 -p1
60%patch2 -p1
61# %patch3 -p1
62
63cp %{SOURCE3} language/plan.lang.japanese
64cp %{SOURCE4} misc/plan_cal.ps
65cp %{SOURCE8} README.vine
66
67%build
68
69chPath(){
70for i in $*; do
71sed -e "s|/usr/local/bin|/usr/bin|g" \
72    -e "s|/usr/local/lib/netplan.dir|/home/netplan|g" \
73    -e "s|/usr/local/lib|%{_libdir}/plan|g" \
74    -e "s|\!/usr/local/bin/perl|\!/usr/bin/perl|g" \
75    -e "s|\!/bin/perl|\!/usr/bin/perl|g" \
76    -e "s|\!/usr/bin/sed|\!/bin/sed|g" \
77    -e "s|\! /usr/local/bin/perl|\!/usr/bin/perl|g" \
78    -e "s|\! /bin/perl|\!/usr/bin/perl|g" \
79    -e "s|\! /usr/bin/sed|\!/bin/sed|g" \
80    $i > $i.new
81mv $i.new $i
82done
83}
84
85(cd misc
86chPath vsc cvs Mkdoc msschedule2plan Killpland
87)
88
89cp %{SOURCE2} holiday/holiday_japan
90
91(cd src
92make linux
93)
94(
95cd web
96for i in *.cgi common.pl; do
97        chPath $i
98done
99)
100
101%install
102[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
103mkdir -p %{buildroot}/usr/X11R6/lib/X11/app-defaults
104install -m 644 %{SOURCE1} %{buildroot}/usr/X11R6/lib/X11/app-defaults/Plan
105
106(cd src
107mkdir -p %{buildroot}/usr/{bin,lib}
108mkdir -p %{buildroot}%{_libdir}/plan
109mkdir -p %{buildroot}/home/netplan
110make DESTDIR=%{buildroot} install
111)
112
113mv %{buildroot}%{_bindir}/plan %{buildroot}%{_bindir}/plan.bin
114install -m 755 %{SOURCE6} %{buildroot}%{_bindir}/plan
115install -m 755 %{SOURCE7} %{buildroot}%{_sbindir}/netplangrpadd
116
117mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
118install -m 755 %{SOURCE5} %{buildroot}%{_sysconfdir}/rc.d/init.d/netplan
119
120(cd web
121mkdir -p %{buildroot}/home/httpd/html/plan/
122install -m 755 *.cgi %{buildroot}/home/httpd/html/plan/
123install -m 644 *.pl %{buildroot}/home/httpd/html/plan/
124install -m 644 *.{html,jpg} holiday_webplan %{buildroot}/home/httpd/html/plan/
125)
126
127(cd misc
128install -m 755 msschedule2plan Killpland %{buildroot}%{_bindir}
129mkdir -p %{buildroot}%{_mandir}/{man1,man4}
130install *.1 %{buildroot}%{_mandir}/man1
131install *.4 %{buildroot}%{_mandir}/man4
132
133#prepare for doc
134rm *.1 *.4 *cat msschedule2plan Killpland *.ps
135)
136
137cat > %{buildroot}/home/netplan/.netplan-acl<<EOF
138#Examples(see man netplan in detail)
139#*: permit read
140#*: permit write host daphne
141#thomas: deny user *
142#thomas: permit read write delete user 207 208
143#announce: permit write netmask 255.255.255.0 host 10.0.1.0
144#
145*: permit read
146EOF
147
148%clean
149[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
150
151
152%files
153%defattr(-,root,root)
154%doc README* HISTORY holiday/
155%doc misc/
156%{_sysconfdir}/rc.d/init.d/netplan
157/home/httpd/html/plan/
158/usr/X11R6/lib/X11/app-defaults/Plan
159%{_bindir}/plan
160%{_bindir}/plan.bin
161%{_bindir}/msschedule2plan
162%{_bindir}/Killpland
163%attr(755,-,-)%dir %{_libdir}/plan/
164%{_libdir}/plan/pland
165%{_libdir}/plan/notifier
166%{_libdir}/plan/plan.help
167%{_libdir}/plan/plan.lang.*
168%{_libdir}/plan/plan*.ps
169%{_sbindir}/netplan
170%{_sbindir}/netplangrpadd
171%attr(1700,nobody,nobody)%dir /home/netplan/
172%attr(-,nobody,nobody)%config(noreplace) /home/netplan/.netplan-acl
173%{_mandir}/man1/plan.1*
174%{_mandir}/man1/netplan.1*
175%{_mandir}/man4/plan.4*
176
177%changelog
178* Tue Oct 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.8.7-0vl5
179- rebuilt for Vine Linux 4.0
180- s/Copyright/License/
181- added %clean section
182
183* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 1.8.7-0vl4
184- build on Vine 3.1
185- added byacc, flex in BuildPreReq
186
187* Wed Feb 23 2005 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl3
188- fix plan.sh
189- update holiday_japan
190
191* Tue Feb 22 2005 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl2
192- update holiday_japan
193
194* Mon Oct 27 2003 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl1
195- ver.up
196
197* Mon Jun  2 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl6
198- build with openMotif
199
200* Mon Feb 17 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl5
201- update holiday_japan
202
203* Wed Jan 22 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl4
204- plan-1.8.4-jp2.vine.patch (fix locale handling for printing)
205- smaller default fonts in month view
206
207* Fri Jan 18 2002 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl3
208- rebuild with gcc-2.95.3
209- update holiday_japan
210
211* Wed May  9 2001 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl2
212- fix LOCALE_EUC as ja_JP.eucJP
213- use more macros in spec
214
215* Fri Apr 20 2001 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl1
216- ver.up
217- move netplan.dir to /home/netplan
218- many improvements
219
220* Tue Feb  6 2001 Jun Nishii <jun@vinelinux.org>
221- 1.8.3-0vl4
222- fix path in common.pl
223
224* Fri Oct  6 2000 Jun Nishii <jun@vinelinux.org>
225- 1.8.3-0vl3
226- updated holiday_japan
227
228* Wed Jun 14 2000 Jun Nishii <jun@vinelinux.org>
229- 1.8.3-0vl2
230- merge plan_calEUC.ps from vine-useres:023414
231
232* Fri Feb 11 2000 Jun Nishii <jun@vinelinux.org>
233- 1.8.3
234- merge japanese patch from http://cgi.shikoku.ne.jp/~fun/srpms.html
235
Note: See TracBrowser for help on using the repository browser.