source: projects/specs/branches/6/p/pkgconfig/pkgconfig-vl.spec @ 3534

Revision 3534, 5.4 KB checked in by owa, 13 years ago (diff)

rebuit

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.25
7Release: 2%{?_dist_release}
8Epoch: 1
9
10Group: Development/Tools
11License: GPLv2
12Source: http://pkgconfig.freedesktop.org/releases/pkg-config-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel
16BuildRequires: popt-devel
17
18%description
19The pkgconfig tool determines compilation options. For each required
20library, it reads the configuration file and outputs the necessary
21compiler and linker flags.
22
23%description -l ja
24pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
25要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
26フラグとリンカフラグを出力します。
27
28
29## to build compat32 for x86_64 architecture support
30%package -n compat32-%{name}
31Summary: A tool for determining compilation options.
32Summary(ja): コンパイルオプションを決定するためのツール
33Group: Development/Tools
34
35%description -n compat32-%{name}
36The pkgconfig tool determines compilation options. For each required
37library, it reads the configuration file and outputs the necessary
38compiler and linker flags.
39
40
41%prep
42%setup -q -n pkg-config-%{version}
43
44%build
45%configure \
46    --with-installed-glib \
47    --with-installed-popt
48
49make
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall
54
55mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
56mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
57#strip $RPM_BUILD_ROOT%{_bindir}/*
58
59rm -rf $RPM_BUILD_ROOT%{_docdir}/pkg-config
60
61%if %{build_compat32}
62%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
63%endif
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root)
70%doc AUTHORS COPYING ChangeLog NEWS README pkg-config-guide.html
71%{_bindir}/pkg-config
72%dir %{_libdir}/pkgconfig
73%dir %{_datadir}/pkgconfig
74%{_datadir}/aclocal/*.m4
75%{_mandir}/*/*
76
77%if %{build_compat32}
78%files -n compat32-%{name}
79%defattr(-,root,root)
80%{_bindir}/pkg-config-32
81%dir %{_libdir}/pkgconfig
82%endif
83
84
85%changelog
86* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1:0.25-2
87- rebuilt with rpm-4.8.1-3
88
89* Thu Sep 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.25-1
90- new upstream release
91- added BR: glib2-devel, popt-devel to build with installed libraries
92
93* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
94- rebuild to fix the package built with broken environment.
95
96* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
97- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
98
99* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
100- removed %%if !%%{build_compat32} case condition
101
102* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
103- spec in utf-8
104
105* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
106- applied new versioning policy
107
108* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
109- new upstream release
110
111* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
112- new upstream release
113
114* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
115- fix compat32 package
116  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
117  - add %%{_bindir}/pkg-config-32
118- not srtip at %%install, it should be done by %__install_spec_post
119
120* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
121- added compat32-* packages for x86_64 architecture support
122
123* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
124- new upstream release
125
126* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
127- new upstream release
128
129* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
130- new upstream release
131- added Japanese description (from vinedocs.sourceforge.jp)
132
133* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
134- add Epoch: 1 to be able to upgrade from VinePlus package.
135
136* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
137- new upstream release
138
139* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
140- rebuild for Vine Linux
141
142* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
143- 0.14
144
145* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
146- use libdir, so we do move .pc files to /usr/lib64
147
148* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
149- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
150
151* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
152- automated rebuild
153
154* Thu May 23 2002 Tim Powers <timp@redhat.com>
155- automated rebuild
156
157* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
158- 0.12.0
159
160* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
161- 0.11.0
162
163* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
164- backbuild in gnomehide
165
166* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
167- 0.10.0
168
169* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
170- 0.9.0
171
172* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
173- automated rebuild
174
175* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
176- call libtoolize to make porting to new archs easier
177
178* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
179- put pkg.m4 in file list
180
181* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
182- Upgrade to 0.7
183- add man page
184
185* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
186- Upgrade to 0.5
187
188* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
189- rebuild because of broken fileutils
190
191* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
192- Initial package
Note: See TracBrowser for help on using the repository browser.