source: projects/specs/branches/6/p/pk300/pk300-vl.spec @ 521

Revision 521, 2.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _prefix         /usr
2%define texmf           %{_prefix}/share/texmf
3%define texmfconf       %{texmf}/web2c/texmf.cnf
4%define mode            epsonact
5%define fontdir         %{_prefix}/share/fonts/pk
6
7%define exec_texhash    [ -x %{_prefix}/bin/texhash ] && /usr/bin/env - %{_prefix}/bin/texhash 2> /dev/null
8%define part_delete     if [ -e $CONF ]; then cp -f $CONF $CONF.rpmtmp && sed -e '/^. begin %{name} /,/^. end %{name} /d' < $CONF.rpmtmp > $CONF && rm -f $CONF.rpmtmp; fi
9
10Summary: 300 dpi TeX pk fonts
11Name: pk300
12Version: 1
13Release: 5%{?_dist_release}
14License: distributable
15Group: Applications/Publishing
16Source0: http://www.tooyoo.l.u-tokyo.ac.jp/TeX/utility/makefont.tar.gz
17Source1: makefonts-pje.tar.gz
18BuildArch: noarch
19PreReq: sed sh-utils
20#Requires: tetex-xdvi
21Requires: xdvik
22BuildPreReq: tetex
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28300 dpi PK fonts for TeX. Only for xdvi.
29
30%description -l ja
31TeX で利用する pk font (300dpi)です。xdvi でのみ用います。
32
33%prep
34%setup -q -c -T -a 0 -a 1
35cp latex2e.medium.sh latex2e.sh
36cp ams.small.sh ams.sh
37
38%build
39make MODE=%{mode} latex2e
40make MODE=%{mode} slitex
41make MODE=%{mode} ams
42
43%install
44rm -rf ${RPM_BUILD_ROOT}
45mkdir -p $RPM_BUILD_ROOT%{fontdir}/%{mode}
46make PKDIR=$RPM_BUILD_ROOT%{fontdir}/%{mode} install
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52%{exec_texhash}
53exit 0
54
55%postun
56%{exec_texhash}
57exit 0
58
59
60%files
61%defattr(-, root, root)
62%{fontdir}/%{mode}
63
64%changelog
65* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1-5vl5
66- applied new versioning policy, spec in utf-8
67
68* Tue Jun 25 2002 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 1-4vl3
69- remove trigger/triggerun (PKFONTS.xdvi already exists in texmf.cnf)
70
71* Thu Aug 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
72- 1-4vl2
73- Requires: tetex-xdvi -> xdvik again
74
75* Fri Jul 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
76- pk300-1-4vl1 derived from Mr. Tutimura's 0test5.
77
78* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
79- Change Group.
80- add defattr(-, root, root)
81
82* Thu Dec 3 1998 Jun NISHII <nishii@postman.riken.go.jp>
83- Mmm... more slim!
84
85* Thu Nov 26 1998 Jun NISHII <nishii@postman.riken.go.jp>
86- more fonts!
87
88* Thu Nov 05 1998 Jun NISHII <nishii@postman.riken.go.jp>
89- first release
Note: See TracBrowser for help on using the repository browser.