source: projects/specs/branches/6/p/pilot-link/pilot-link-vl.spec @ 6208

Revision 6208, 8.5 KB checked in by inagaki, 12 years ago (diff)

update: libcaptury, libfli, libmal, libnova, libotr, libqalculate, libvncserver and pilot-link

Line 
1%define ver     0.12.5
2%define srcver  %{ver}
3%define rel     2%{?_dist_release}
4%define support_perl 0
5
6Name:           pilot-link
7Summary:        File transfer utilities between Linux and PalmPilots.
8Summary(ja):    Linux と Palm handheld device を接続する為のユーティリティ
9Version:        %{ver}
10Release:        %{rel}
11Epoch:          1
12
13Group:          Applications/Other
14License:        GPL/LGPL
15URL:            http://www.pilot-link.org/
16
17Source0:        http://downloads.pilot-link.org/pilot-link-%{version}.tar.bz2
18Source1:        connect-palm-ppp.tar.bz2
19Source2:        60-libpisock.rules.vine
20
21# (fc) 0.10.99 fix python/perl installation
22Patch1:         pilot-link-0.11.0-perlmd5.patch
23Patch2:         pilot-link-0.11.0-perlpollute.patch
24Patch3:         pilot-link-0.11.2-malsync.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  bison >= 1.35
28BuildRequires:  libusb-devel >= 0.1
29BuildRequires:  readline-devel
30BuildRequires:  bluez-libs-devel
31BuildRequires:  popt-devel
32%if %{support_perl}
33BuildRequires:  perl
34%endif
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38
39%description
40This suite of tools allows you to upload and download programs and
41data files between a Linux/UNIX machine and the PalmPilot.  It has a
42few extra utils that will allow for things like syncing the
43PalmPilot's calendar app with Ical.  Note that you might still need to
44consult the sources for pilot-link if you would like the Python, Tcl,
45or Perl bindings.
46
47Install pilot-link if you want to synchronize your Palm with your Vine
48Linux system.
49
50%description -l ja
51このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
52プログラムやファイルを転送することができます。このツールには、Palm
53handheld device の予定表と Ical との間で同期を可能にするようないくつ
54かのユーティリティが付属しています。もし Python や Tcl、あるいは
55Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
56あることに注意してください。
57
58Palm handheld device を Vine Linux システムで同期させたい場合は
59pilot-link をインストールします。
60
61%package libs
62Summary:        Runtime libraries for %{name}
63Summary(ja):    %{name} のランタイムライブラリ
64Group:          System Environment/Libraries
65Requires:       libusb >= 0.1
66
67%description libs
68This package provides the shared libraries for any pilot-link client
69program or interface.
70
71%package devel
72Summary:        PalmPilot development header files.
73Summary(ja):    Palm handheld プログラム開発用のヘッダ ファイル
74Group:          Development/Libraries
75Requires:       %{name}-libs = %{epoch}:%{version}
76
77%description devel
78This package contains the development headers that are used to build
79the pilot-link package.  It also includes the static libraries
80necessary to build static pilot apps.
81
82If you want to develop PalmPilot synchronizing applications, you'll
83need to install pilot-link-devel.
84
85%description devel -l ja
86このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
87ヘッダ ファイルが含まれます。また、スタティックな Palm 用アプリケーション
88の構築に必要なスタティック ライブラリも含まれます。
89
90Palm handheld deviceと同期するアプリケーションを開発したい場合は、
91pilot-link-devel パッケージをインストールする必要があります。
92
93%prep
94%setup -q -a 1
95%if %{support_perl}
96%patch1 -p1 -b .perlmd5
97%patch2 -p1 -b .perlpollute
98%patch3 -p1 -b .malsync
99%endif
100
101%build
102%configure\
103  --disable-static \
104  --enable-conduits \
105  --enable-libusb \
106  --with-libpng \
107  --with-bluez \
108  --without-python \
109  --without-tcl \
110  --without-java \
111%if %{support_perl}
112  --with-perl
113%else
114  --without-perl
115%endif
116
117make
118
119%install
120[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
121
122%if %{support_perl}
123if test -f bindings/Perl/Makefile.PL ; then
124   cd bindings/Perl
125   perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
126   CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
127   make
128   cd ../..
129fi
130%endif
131
132%__make install DESTDIR=$RPM_BUILD_ROOT
133#%makeinstall -C doc/man
134
135%if %{support_perl}
136make install -C bindings/Perl
137rm -f %{buildroot}%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
138      %{buildroot}%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
139%endif
140
141# install modified udev rules.
142mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
143install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
144
145# remove files we don't want to include
146rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
147
148%post libs -p /sbin/ldconfig
149
150%postun libs -p /sbin/ldconfig
151
152
153%clean
154[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(-,root,root)
158%doc COPYING ChangeLog README NEWS AUTHORS doc/README.*
159%{_bindir}/*
160%{_mandir}/man1/*
161
162%files libs
163%defattr(-,root,root)
164%doc COPYING.LIB
165%{_sysconfdir}/udev/rules.d/60-libpisock.rules
166%{_libdir}/*.so.*
167%if %{support_perl}
168%{_libdir}/perl5/vendor_perl/*/*/*/PDA
169%{_libdir}/perl5/vendor_perl/*/*/PDA
170%endif
171%{_datadir}/pilot-link
172%{_mandir}/man7/*
173
174%files devel
175%defattr(-, root, root)
176%{_libdir}/*.so
177#{_libdir}/*.la
178%{_libdir}/pkgconfig/pilot-link.pc
179%{_includedir}/*
180%{_datadir}/aclocal/*.m4
181
182
183%changelog
184* Mon May 21 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.5-2
185- rebuild with rpm-4.8.1-3
186
187* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.5-1
188- new upstream release
189- split libraries to subpackage
190- built with rpm-4.8.1 for pkg-config
191- added URL tag
192
193* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
194- new upstream release
195- removed static libraries from devel package
196- added --with-bluez to %%configure (added also BR: bluez-libs-devel)
197
198* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
199- applied new versioning policy, spec in utf-8
200
201* Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
202- add modified udev rules (Source2). <BTS:VineLinux:222>
203
204* Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
205- source update.
206- change Group to Applications/Other
207- use %%configure macro instead of ./configure
208- delete unused configure options for itcl and tk.
209- use '%%__make install' to use DESTDIR variable.
210- comment out '%%makeinstall -C doc/man'(not required to install man).
211- add 60-libpisock.rules for udev in %%files.
212- add pilot-link.pc in %%files for -devel.
213- add Requires libusb and BuildRequires libusb-devel >= 0.1.
214
215* Fri Jan  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
216- rebuild for VineSeed
217- add "%%{epoch}:" to Requires in pilot-link-devel
218
219* Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
220- convert spec from SJIS to EUC.
221
222* Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
223- source update
224- add japanese translation(summary & description).
225- use License tag instead of Copyright.
226- change BuildRequires XFree86-devel to XOrg-devel.
227- add BuildRequires readline-devel.
228- add new Patch9.(avoid make error "undefined reference to `pow'")
229
230* Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
231- disuse %%configure macro to avoid unsuitable prefixed filename
232
233* Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
234- source update
235
236* Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
237- unfortunately added Epoch 1
238  (the previous version was 0.9.5.pre5-0vl2. Sigh...)
239
240* Sat Oct 13 2001 <uh@u.dhis.portside.net>
241- 0.9.5-0vl1
242- upgrade to 0.9.5
243- add COPYING.LIB to %doc
244
245* Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
246- New upstream release.
247- Fixed defattr stuff for devel package.
248- Use rpmmacros.
249
250* Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
251- upgrade to pilot-link 0.9.3, rewrite spec.
252
253* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
254- strip binaries
255
256* Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
257- added missing files from devel subpackage
258
259* Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
260- move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
261
262* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
263- auto rebuild in the new build environment (release 5)
264
265* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
266- Injected new description and group.
267
268* Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
269- arm fix
270
271* Fri Sep 24 1998 Michael Maher <mike@redhat.com>
272- cleaned up spec file, updated package
273
274* Tue May 19 1998 Michael Maher <mike@redhat.com>
275- updated rpm
276
277* Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
278- added changelog
279- updated to 0.8.9
280- removed explicit requires for /usr/bin/perl
281
Note: See TracBrowser for help on using the repository browser.