source: projects/specs/branches/6/p/physfs/physfs-vl.spec @ 7739

Revision 7739, 4.7 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild packages & security fix

Line 
1%define name physfs
2%define version 1.1.1
3%define release 2%{?_dist_release}
4
5Summary: Library to provide abstract access to various archives
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source0: http://icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
10License: BSD
11Group: System Environment/Libraries
12URL: http://icculus.org/physfs/
13
14BuildRequires: doxygen
15BuildRequires: zlib-devel
16BuildRequires: readline-devel
17BuildRequires: wx-gtk2-devel
18BuildRequires: cmake
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22 PhysicsFS is a library to provide abstract access to various archives.
23It is intended for use in video games, and the design was somewhat
24inspired by Quake 3's file subsystem.
25The programmer defines a "write directory" on the physical filesystem.
26No file writing done through the PhysicsFS API can leave that write directory,
27for security.
28For example, an embedded scripting language cannot write outside
29of this path if it uses PhysFS for all of its I/O, which means
30that untrusted scripts can run more safely.
31Symbolic links can be disabled as well, for added safety.
32For file reading, the programmer lists directories and archives
33that form a "search path".
34Once the search path is defined, it becomes a single,
35transparent hierarchical filesystem.
36This makes for easy access to ZIP files in the same way
37as you access a file directly on the disk,
38and it makes it easy to ship a new archive
39that will override a previous archive on a per-file basis.
40Finally, PhysicsFS gives you platform-abstracted means to determine
41if CD-ROMs are available, the user's home directory,
42where in the real filesystem your program is running, etc.
43
44%package devel
45Summary: Development libraries and headers for physfs
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50This package contains the libraries and headers necessary for developing
51packages with physfs functionality.
52
53
54%prep
55%setup -q
56
57%build
58%ifarch x86_64
59mv CMakeLists.txt CMakeLists.txt.orig
60cat CMakeLists.txt.orig \
61        | sed "s/LIBRARY DESTINATION lib/LIBRARY DESTINATION %{_lib}/" \
62        | sed "s/ARCHIVE DESTINATION lib/ARCHIVE DESTINATION %{_lib}/" \
63        > CMakeLists.txt
64%endif
65cmake -D CMAKE_INSTALL_PREFIX=%{_prefix} .
66make %{?_smp_mflags}
67doxygen
68
69%install
70%{__rm} -rf ${RPM_BUILD_ROOT}
71make DESTDIR=${RPM_BUILD_ROOT} install
72#%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.la
73mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
74install -m0644 docs/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
75
76# Handle man page conflicts (bz #183705) from Fedora
77mv $RPM_BUILD_ROOT%{_mandir}/man3/author.3 \
78    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-author.3
79mv $RPM_BUILD_ROOT%{_mandir}/man3/description.3 \
80    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-description.3
81mv $RPM_BUILD_ROOT%{_mandir}/man3/extension.3 \
82    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-extension.3
83mv $RPM_BUILD_ROOT%{_mandir}/man3/major.3 \
84    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-major.3
85mv $RPM_BUILD_ROOT%{_mandir}/man3/minor.3 \
86    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-minor.3
87mv $RPM_BUILD_ROOT%{_mandir}/man3/patch.3 \
88    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-patch.3
89mv $RPM_BUILD_ROOT%{_mandir}/man3/url.3 \
90    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-url.3
91
92%clean
93%{__rm} -rf ${RPM_BUILD_ROOT}
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%doc CHANGELOG.txt CREDITS.txt LICENSE.txt TODO.txt
102%{_libdir}/*.so.*
103%{_bindir}/test_physfs
104%{_bindir}/wxtest_physfs
105
106%files devel
107%defattr(-,root,root,-)
108%doc docs/html/ docs/latex/
109%{_includedir}/physfs.h
110%{_libdir}/*.a
111#%{_libdir}/*.la
112%{_libdir}/*.so
113%{_mandir}/man3/*
114
115%changelog
116* Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
117- rebuild with current Vine6 environment
118- add BuildRequires: wx-gtk2-devel
119
120* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
121- applied new versioning policy
122
123* Wed Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl3
124- updated CMakeLists.txt for lib64
125
126* Fri Sep 07 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl2
127- remove "-D PHYSFS_BUILD_TEST:BOOL=OFF" from cmake option.
128- add test_physfs to %%files.
129
130* Wed Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
131- new upstream release.
132- add "BuildRequires: cmake".
133- to use cmake instead of %%configure.
134- update %%files.
135- temporarily remove test_physfs from %%files.
136- remove libphysfs.la from %%files devel.
137
138* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
139- initial build for Vine Linux 4.1
140
141* Mon Oct 17 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vlmp2
142- change Group: System Environment/Libraries
143
144* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.0-0vlmp1
145- initial build for Vine Linux 3.2
146
147# end of file
Note: See TracBrowser for help on using the repository browser.