source: projects/specs/branches/6/p/php-ext-memcache/php-ext-memcache-vl.spec @ 6107

Revision 6107, 1.7 KB checked in by tomop, 12 years ago (diff)

added PHP extensions.

  • Property svn:executable set to *
Line 
1Summary: memcache extension for PHP
2Summary(ja): PHP用memcache拡張
3Name: php-ext-memcache
4Version: 2.2.6
5Release: 3%{_dist_release}
6Source: memcache-%{version}.tgz
7Patch0: memcache-2.2.6-session_strict.patch
8License: The PHP License
9Group: Development/Languages
10BuildRequires: php5-devel
11BuildRequires: zlib-devel
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: %{req_php_api}
14
15%description
16This module enable to access memcached in PHP scripts.
17
18%description -l ja
19このモジュールは、PHPスクリプト中でmemcachedにアクセスできるようにします。
20
21%prep
22%setup -q -n memcache-%{version}
23%patch0 -p1 -b .session_strict
24mv ../package.xml ./
25phpize
26
27%build
28%configure --enable-memcache-session=yes
29%__make %{?_smp_mflags}
30
31%install
32rm -rf %{buildroot}
33mkdir -p %{buildroot}%{_libdir}/php5/
34mkdir -p %{buildroot}%{_sysconfdir}/php5/php.d
35%makeinstall INSTALL_ROOT=%{buildroot}
36
37
38cat > %{buildroot}%{_sysconfdir}/php5/php.d/memcache.ini <<EOF
39; Enable memcache extension module
40extension=memcache.so
41
42memcache.allow_failover = 1
43memcache.max_failover_attempts = 20
44memcache.chunk_size = 16384
45memcache.default_port = 11211
46memcache.hash_function = crc32
47memcache.hash_strategy = consistent
48EOF
49
50
51%clean
52rm -rf %{buildroot}
53
54%files
55%defattr(-,root,root)
56%doc CREDITS README
57%{_libdir}/php5/*
58%config(noreplace) %{_sysconfdir}/php5/php.d/*
59
60%changelog
61* Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-3
62- converted encoding to UTF-8.
63
64* Sat Apr 28 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-2
65- rebuilt with current environment.
66
67* Mon Dec 13 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
68- new upstream release.
69
70* Fri Jul 10 2009 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.4-1
71- initial build.
72
Note: See TracBrowser for help on using the repository browser.