source: projects/specs/branches/6/p/phonon/phonon-vl.spec @ 4048

Revision 4048, 5.6 KB checked in by inagaki, 13 years ago (diff)

add: libqzeitgeist
update: phonon, phonon-backend-gstreamer, phonon-backend-xine

Line 
1%define qt4_ver 4.7.2
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
5%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
6
7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
8
9Name: phonon
10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
12Version: 4.5.0
13Release: 1%{?_dist_release}
14
15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.4/phonon-%{version}.tar.bz2
20
21Patch1: phonon-4.4.4-no_rpath.patch
22## Mandriva/upstreamable patches
23Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
24
25## Upstream patches
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: automoc4 >= 0.9.86
29BuildRequires: cmake >= 2.6.2
30BuildRequires: glib2-devel
31BuildRequires: libqzeitgeist-devel
32BuildRequires: libxcb-devel
33BuildRequires: libxml2-devel
34BuildRequires: qt4-devel >= 4.6.0
35BuildRequires: pulseaudio-libs-devel >= 0.9.15
36
37# TODO: enable the following Requires in next release
38Requires: phonon-backend >= 4.4
39Requires: pulseaudio-libs >= %{pulseaudio_version}
40Requires: qt4 >= %{_qt4_version}
41
42%description
43Phonon is a cross-platform portable Multimedia Support Abstraction,
44which allows you to play multiple audio or video formats with the same
45quality on all platforms, no matter which underlying architecture is
46used.
47
48%package devel
49Summary: Development files for phonon
50Summary(ja): phonon の開発用ファイル
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: qt4-devel = %{_qt4_version}
54
55%description devel
56Header files for developing applications using phonon
57
58%prep
59%setup -q
60
61%patch1 -p1 -b .no_rpath
62%patch53 -p1 -b .phonon-allow-stop-empty-source
63
64
65%build
66%ifarch x86_64
67PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
68%endif
69
70mkdir -p %{_target_platform}
71pushd %{_target_platform}
72unset QTDIR || : ; . /etc/profile.d/qt4.sh
73%cmake \
74    ..
75popd
76
77make %{?_smp_mflags} -C %{_target_platform}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
83
84# symlink for qt/phonon compatibility
85ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
86
87# own these dirs
88mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
89mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
90
91mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}
92pushd $RPM_BUILD_ROOT%{_qt4_headerdir}
93ln -sf %{_includedir}/phonon phonon
94popd
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(-,root,root)
105%doc COPYING.LIB
106%{_libdir}/*.so.*
107%{_qt4_plugindir}/designer/*.so
108%{_datadir}/dbus-1/interfaces/*
109# kde4-specific dirs
110%dir %{_libdir}/kde4/plugins/phonon_backend
111%dir %{_datadir}/kde4/services/phononbackends
112
113%files devel
114%defattr(-,root,root)
115%dir %{_includedir}/KDE
116%{_includedir}/KDE/Phonon/
117%{_includedir}/phonon/
118%{_qt4_headerdir}/phonon
119%{_qt4_prefix}/mkspecs/modules/qt_phonon.pri
120%{_libdir}/*.so
121%{_libdir}/pkgconfig/*.pc
122%{_datadir}/phonon-buildsystem/
123
124%changelog
125* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
126- new upstream release
127- added BR: libqzeitgeist-devel
128
129* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
130- rebuilt with qt4-4.7.2
131
132* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
133- new upstream release
134- rebuilt with qt4-4.7.1 on VineSeed
135
136* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
137- new upstream release
138
139* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
140- added sybolic link in %%{_qt4_headerdir}
141
142* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
143- new upstream release
144- dropt Patch51 and 57
145- rebuilt with rpm-4.8.1
146
147* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
148- new upstream release
149- dropt Patch1, 50, 54 and 100
150- added Patch57
151  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
152  - F11: patch/modularize pa device-manager bits
153
154* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
155- added qmake path to PATH (if x86_64)
156
157* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
158- new upstream release
159- built with new toolchain
160
161* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
162- added Patch102 and 103 from FC
163  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
164  - fix for '#' in filenames
165  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
166  - restore patches to the xine backend
167
168* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
169- added Patch100 and 101 from FC
170  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
171  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
172- added backend sub-pakcages
173
174* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
175- new upstream release
176- add BuildPrereq: cmake
177
178* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
179- new upstream release
180
181* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
182- new upstream release
183- update %%files
184- add BuildPrereq: xine-lib-devel libxcb-devel
185
186* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
187- new upstream release
188
189* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
190- added script to append qmake path
191- added option -DLIB_INSTALL_DIR at cmake
192
193* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
194- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.