source: projects/specs/branches/6/p/pgperl/pgperl-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: a libpq-based PostgreSQL interface for Perl
2Name: pgperl
3Version: 2.0.2
4Release: 2%{?_dist_release}
5URL: http://gborg.postgresql.org/project/pgperl/projdisplay.php
6Source0: ftp://gborg.postgresql.org/pub/pgperl/stable/%{name}-%{version}.tar.gz
7License: Perl's
8Group: Development/Libraries
9BuildRoot: %{_tmppath}/%{name}-root
10Requires: postgresql-libs
11BuildRequires: postgresql-devel perl
12Obsoletes: postgresql-perl
13
14%description
15pgperl is an interface between Perl and PostgreSQL. This uses the Perl5
16API for C extensions to call the PostgreSQL libpq interface. Unlike
17DBD:pg, pgperl tries to implement the libpq interface as closely as
18possible.
19
20You have a choice between two different interfaces: the old C-style
21interface and a new one, using a more Perl-ish style. The old style has
22the benefit that existing libpq applications can easily be ported to
23perl. The new style uses class packages and might be more familiar to
24C++ programmers.
25
26%prep
27%setup -q -n Pg-%{version}
28
29%build
30export POSTGRES_INCLUDE=%{_includedir}/pgsql
31export POSTGRES_LIB=%{_libdir}
32perl Makefile.PL INSTALLDIRS=vendor
33make
34
35%install
36rm -rf %{buildroot}
37make DESTDIR=$RPM_BUILD_ROOT install
38#make PREFIX=%{buildroot}%{_prefix} \
39#     INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
40#     INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 install
41
42find $RPM_BUILD_ROOT%{_prefix} -type f -print |
43        sed "s@^$RPM_BUILD_ROOT@@g" |
44        grep -v perllocal.pod       |
45        grep -v "\.packlist"        |
46        grep -v ^%{_mandir}         > %{name}.files
47if [ "$(cat %{name}.files)X" = "X" ] ; then
48    echo "ERROR: EMPTY FILE LIST"
49    exit -1
50fi
51
52%clean
53rm -rf %{buildroot}
54
55%files -f %{name}.files
56%defattr(-,root,root)
57%doc README Changes examples
58%{_mandir}/man3/Pg.3pm*
59%dir %{perl_vendorarch}/auto
60%dir %{perl_vendorarch}/auto/Pg
61
62%changelog
63* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0.2-2
64- rebuilt with postgresql-8.4.0
65
66* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.2-1vl5
67- applied new versioning policy
68- rebuilt with postgresql-8.3.3
69
70* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl5
71- rebuilt with postgresql-8.2.6
72
73* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl4
74- rebuilt with postgresql-8.2.5
75
76* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl3
77- changed Group to Development/Libraries
78
79* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl2
80- rebuilt with postgresql-8.0.x
81
82* Sat Apr 26 2003 IWAI Masaharu <iwai@alib.jp> 2.0.2-0vl1
83- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.