source: projects/specs/branches/6/p/pessulus/pessulus-vl.spec @ 2219

Revision 2219, 5.2 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define basever 2.30
3
4Name:           pessulus
5Version:        %{basever}.4
6Release:        1%{?_dist_release}
7Summary:        A lockdown editor for GNOME
8
9Group:          Applications/System
10License:        GPLv2+
11URL:            http://live.gnome.org/Pessulus
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{basever}/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildArch:      noarch
15
16BuildRequires:  gtk2-devel
17BuildRequires:  pygtk2-devel
18BuildRequires:  gnome-python-devel
19BuildRequires:  GConf2-devel
20BuildRequires:  gnome-python-desktop
21BuildRequires:  perl-XML-Parser
22#BuildRequires:  pkgconfig
23BuildRequires:  gettext-devel
24BuildRequires:  intltool >= 0.35.0
25BuildRequires:  desktop-file-utils
26Requires:  gnome-python-desktop
27
28%description
29Pessulus is a lockdown editor for GNOME, written in python. Pessulus
30enables administrators to set mandatory settings in GConf. The
31users can not change these settings.
32Use of pessulus can be useful on computers that are open to use by
33everyone, e.g. in an internet cafe.
34
35%prep
36%setup -q
37
38
39%build
40%configure
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT
47chmod +x $RPM_BUILD_ROOT%{python_sitelib}/Pessulus/*.py
48
49desktop-file-install --vendor="" --delete-original --remove-category="System" \
50  --dir $RPM_BUILD_ROOT%{_datadir}/applications        \
51  $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
52
53%find_lang %{name}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59touch --no-create %{_datadir}/icons/hicolor
60if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
61  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
62fi
63
64%postun
65touch --no-create %{_datadir}/icons/hicolor
66if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
67  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
68fi
69
70%files -f %{name}.lang
71%defattr(-,root,root,-)
72%doc README AUTHORS COPYING ChangeLog
73%{_bindir}/%{name}
74%{python_sitelib}/Pessulus/
75%{_datadir}/applications/*.desktop
76%{_datadir}/%{name}
77%{_datadir}/icons/hicolor/*/apps/pessulus.*
78
79%changelog
80* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
81- new upstream release
82
83* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
84- Initial build for Vine Linux
85
86
87* Tue Apr 06 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-2
88- remove gnome-python2-buddy dependency (#579612)
89
90* Wed Mar 23 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-1
91- Updated to 2.30.0
92- more translations
93
94* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.29.91-1
95- Updated to 2.29.91
96
97* Sun Sep 25 2009 Haïkel Guémar <karlthered@gmail.com> - 2.28.0-1
98- Updated to 2.28.0
99
100* Mon Sep 14 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.92-1
101- Updated to 2.27.92
102
103* Wed Jul 29 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.5-1
104- Updated to 2.24.0
105- Remove now unneeded pythondir patch (GNOME #549728 fixed upstream)
106
107* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-5
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
109
110* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
112
113* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.23.1-3
114- Rebuild for Python 2.6
115
116* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-2
117- fix missing BR, Requires
118
119* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-1
120- fix license tag
121- update to 2.23.1
122- install into pythondir (not pyexecdir)
123
124* Mon Apr 16 2007 Damien Durand <splinux@fedoraproject.org> - 2.16.2-2
125- Fix desktop-file
126
127* Fri Dec 22 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.2-1
128- Upgrade to 2.16.2
129- Add gnome-python2-devel in BR
130
131* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.1-1
132- Upgrade to 2.16.1
133- Fixe #195819
134
135* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16-4
136- Bump release
137
138* Wed Sep 06 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.0-1
139- Upgrade to 2.16 release
140- Add gnome-python2-gconf in Requires
141
142* Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-2
143- Bump release
144
145* Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-1
146- Upgraded to 2.15.91
147
148* Fri Jul 28 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.90-1
149- Fix URL
150- Upgrad to 2.15.90
151
152* Tue Jul 11 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.4-1
153- upgrad to 0.10.4
154
155* Tue Jul 04 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-3
156- fix debuginfo packages
157
158* Thu Jun 15 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-2
159- fix BuildRequires
160
161* Wed May 3 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-1
162- upgrade version to 0.10.1
163
164* Fri Apr 7 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 0.9-2
165- fix BR
166- remove unnecessary Requires
167- use version-release in changelog entries
168- fix directory ownership
169- use python_sitearch
170- make python "scripts" executable
171
172* Thu Apr 6 2006 Damien Durand <splinux@fedoraproject.org> - 0.9-1
173- Initial package
Note: See TracBrowser for help on using the repository browser.