source: projects/specs/branches/6/p/perl-libxml-perl/perl-libxml-perl-vl.spec @ 3203

Revision 3203, 3.8 KB checked in by iwaim, 13 years ago (diff)

perl-libxml-perl-0.08-2

Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define _use_internal_dependency_generator 0
3
4%define module  libxml-perl
5Summary: A collection of Perl modules for working with XML.
6Name: perl-%{module}
7Version: 0.08
8Release: 2%{?_dist_release}
9License: distributable
10Group: Development/Libraries
11Source0: http://search.cpan.org/CPAN/authors/id/K/KM/KMACLEOD/%{module}-%{version}.tar.gz
12URL: http://search.cpan.org/dist/libxml-perl/
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildArch: noarch
16BuildRequires: perl >= 5.8.2
17BuildRequires: perl-XML-Parser >= 2.19
18Requires: perl >= 5.8.2
19Requires: perl-XML-Parser >= 2.19
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25libxml-perl is a collection of smaller Perl modules, scripts, and
26documents for working with XML in Perl.  libxml-perl software works in
27combination with XML::Parser, PerlSAX, XML::DOM, XML::Grove and
28others.
29
30
31%prep
32%setup -q -n %{module}-%{version}
33
34%build
35CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
36make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT%{_prefix}
41make DESTDIR=$RPM_BUILD_ROOT install
42
43[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
44
45find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
46
47find $RPM_BUILD_ROOT/usr -type f -print |
48        sed "s@^$RPM_BUILD_ROOT@@g" |
49        grep -v perllocal.pod |
50        grep -v "\.packlist" > perl-libxml-perl-%{version}-filelist
51if [ "$(cat perl-libxml-perl-%{version}-filelist)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56%check
57make test || /bin/true
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files -f perl-libxml-perl-%{version}-filelist
63%defattr(-,root,root)
64%doc README ChangeLog Changes doc examples
65%dir %{perl_vendorlib}/Data
66%dir %{perl_vendorlib}/Data/Grove
67%dir %{perl_vendorlib}/XML
68%dir %{perl_vendorlib}/XML/Handler
69%dir %{perl_vendorlib}/XML/Parser
70%dir %{perl_vendorlib}/XML/PatAct
71
72%changelog
73* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 0.08-2vl6
74- build with perl 5.12.3
75- add Vendor and Distribution tags
76- update URL value
77
78* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.0.8-1
79- applied new versioning policy
80- rebuilt with perl-5.10.0-2
81- changed Group to Development/Libraries
82
83* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.0.8-0vl2
84- rebuilt with perl-5.8.6
85- changed Group to Development/Languages
86
87* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.0.8-0vl1
88- new upstream release
89
90* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 0.0.7-28vl4
91- rebuilt on perl-5.8.2
92
93* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 0.0.7-28vl3
94- rebuilt on perl-5.8.1
95
96* Wed Apr 30 2003 IWAI Masaharu <iwai@alib.jp> 0.07-28vl2
97- build with perl-5.8.0
98- add some documents
99- add some directories
100- add perl-XML-Parser's version in {Build,}Requires
101
102* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 0.07-28vl1
103- build for VineLinux
104
105* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
106- automated release bump and build
107
108* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
109- move to vendor_perl
110
111* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
112- automated rebuild
113
114* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 0.07-5
115- imported from mandrake. tweaked man path.
116
117* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 0.07-4mdk
118- Rebuild for the latest perl.
119- Remove Distribution and Vendor tag.
120- Don't run make test for now.
121
122* Tue Mar 13 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 0.07-3mdk
123- BuildArch: noarch
124- add docs
125- rename spec file
126- clean up spec a bit
127- run automated tests
128
129* Sat Sep 16 2000 Stefan van der Eijk <s.vandereijk@chello.nl> 0.07-2mdk
130- Call spec-helper before creating filelist
131
132* Wed Aug 09 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 0.07-1mdk
133- Macroize package
Note: See TracBrowser for help on using the repository browser.