source: projects/specs/branches/6/p/perl-gettext/perl-gettext-vl.spec @ 3719

Revision 3719, 3.4 KB checked in by yasumichi, 13 years ago (diff)

Locale::Gettext が POSIX と衝突する問題の修正

Line 
1%define PackageName gettext
2
3Name: perl-%{PackageName}
4Version: 1.05
5Release: 11%{?_dist_release}
6Summary: Interface to gettext family of functions
7
8Group: Development/Libraries
9License: GPL or Artistic
10Source: http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/gettext-%{version}.tar.gz
11Patch0: perl-gettext-fix-conflict-posix.patch
12URL:    http://search.cpan.org/~pvandry/gettext/
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gettext
16Requires:       gettext
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19Obsoletes: perl-Locale-gettext <= 1.05
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke, inagaki, iwaim
24
25%description
26Perl module gettext - This module give acces to the C library functions
27for internatialization gettext.
28
29
30%prep
31%setup -q -n %{PackageName}-%{version}
32%patch0 -p1
33
34%build
35%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
36make %{?_smp_mflags}
37
38%install
39rm -rf %{buildroot}
40make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
41find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
42find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
43find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
44chmod -R u+w $RPM_BUILD_ROOT/*
45
46%check
47unset LC_MESSAGES
48case "$LANG" in
49''|'C'|'POSIX' )
50  export LANG=en_US.UTF-8;;
51esac
52make test
53
54%clean
55rm -rf %{buildroot}
56
57
58%files
59%defattr(-,root,root,-)
60%doc README
61%{perl_vendorarch}/auto/Locale
62%{perl_vendorarch}/Locale
63%{_mandir}/man3/*.3*
64
65
66%changelog
67* Thu Apr 28 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.05-11
68- add patch0 from http://rt.cpan.org/Public/Bug/Display.html?id=35680
69- add Vendor, Distribution and Packager tag.
70
71* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.05-10vl6
72- rebuild with perl 5.12.3
73
74* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.05-9
75- rebuild with perl-5.10
76- new versioning policy
77
78* Sat Sep  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.05-8vl1
79- new upstream release
80
81* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.03-0vl2
82- build on perl-5.8.6-0vl1
83- update URL
84
85* Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.03-0vl1
86- new upstream release
87- changed Group: and URL:
88- added Prereq: gettext
89- moved perllocal.pod to docdir
90- rebuild with perl 5.8.2
91
92* Tue Oct  7 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.01-14vl2
93- rebuild to remove dependancy at i386
94- rebuild with perl 5.8.1
95
96* Tue Nov 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.01-14vl1
97- build for Vine Linux
98
99* Sun Nov 11 2001 Magic Bumper <dist@conectiva.com.br>
100+ perl-%{PackageName}-1.01-14cl
101- rebuilt against current perl version
102
103* Fri Mar 02 2001 Rodrigo Barbosa <rodrigob@conectiva.com>
104+ perl-gettext-1.01-13cl
105- Removing macros from changelog
106
107* Thu Dec 07 2000 Rodrigo Barbosa <rodrigob@conectiva.com>
108- Added AutoProv: no
109
110* Mon Oct 31 2000 Raul Dias <rsd@conectiva.com>
111- Changed perl from "Requires:" to "Prereq:".
112
113* Sat Oct 28 2000 Raul Dias <rsd@conectiva.com>
114- Updated spec file
115- eliminate sed use
116
117* Fri Sep 29 2000 Raul Dias <rsd@conectiva.com>
118- Updated spec file
119
120* Tue Jun 06 2000 Raul Dias <rsd@conectiva.com>
121- Fixed instalation without %%doc
122
123* Mon May 22 2000 Raul Dias <rsd@conectiva.com.br>
124- New spec allow compiling with perl version 5.00503 and >= 5.6.0
125
126* Fri May 05 2000 Raul Dias <rsd@conectiva.com>
127- New spec format
128
129* Fri Mar 10 2000 Raul Dias <rsd@conectiva.com.br>
130- first build
131
Note: See TracBrowser for help on using the repository browser.