source: projects/specs/branches/6/p/perl-YAML/perl-YAML-vl.spec @ 3120

Revision 3120, 2.0 KB checked in by iwaim, 13 years ago (diff)

perl-YAML-0.72-1

Line 
1%define origname YAML
2
3Summary: YAML Ain't Markup Language (tm) for Perl
4Name: perl-YAML
5Version: 0.72
6Release: 1%{?_dist_release}
7License: perl's
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/%{origname}-%{version}.tar.gz
10Source1: filter-requires-perl-YAML.sh
11Url: http://search.cpan.org/dist/YAML/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl
15Requires: perl
16
17Distribution: Vine Linux
18Vendor: Project Vine
19Packager: iwaim
20
21%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
22%define __find_requires %{SOURCE1}
23%else
24%define __perl_requires %{SOURCE1}
25%endif
26
27%description
28This module has been released to CPAN as YAML::Old, and soon YAML.pm
29will be changed to just be a frontend interface module for all the
30various Perl YAML implementation modules, including YAML::Old.
31
32If you want robust and fast YAML processing using the normal Dump/Load
33API, please consider switching to YAML::XS. It is by far the best Perl
34module for YAML at this time. It requires that you have a C compiler,
35since it is written in C.
36
37%prep
38%setup -q -n %{origname}-%{version}
39
40%build
41CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
42make
43
44%install
45rm -rf $RPM_BUILD_ROOT
46mkdir -p $RPM_BUILD_ROOT%{_prefix}
47make DESTDIR=$RPM_BUILD_ROOT install
48
49find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
50
51find $RPM_BUILD_ROOT%{_prefix} -type f -print |
52        sed "s@^$RPM_BUILD_ROOT@@g" |
53        grep -v ^%{_mandir} |
54        grep -v perllocal.pod |
55        grep -v "\.packlist" > %{name}.files
56if [ "$(cat %{name}.files)X" = "X" ] ; then
57    echo "ERROR: EMPTY FILE LIST"
58    exit -1
59fi
60
61%check
62make test
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc README Changes LICENSE
70%dir %{perl_vendorlib}/YAML
71%{_mandir}/man3/*
72
73%changelog
74* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 0.72-1
75- new upstream release
76- using __perl_requires macro for VineSeed (vl6)
77
78* Mon Feb 22 2010 IWAI, Masaharu <iwai@alib.jp> 0.71-1
79- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.