source: projects/specs/branches/6/p/perl-XML-SAX/perl-XML-SAX-vl.spec @ 3153

Revision 3153, 3.6 KB checked in by Takemikaduchi, 13 years ago (diff)

freeglut: add BR and Patch, others: rebuild with perl-5.12.3

Line 
1Summary: SAX(Simple API for XML) for Perl
2Name: perl-XML-SAX
3Version: 0.16
4Release: 3%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7Source0: http://www.cpan.org/authors/id/M/MS/MSERGEANT/XML-SAX-%{version}.tar.gz
8Source1: filter-requires-XML-SAX.sh
9Source2: filter-provides-XML-SAX.sh
10
11URL: http://search.cpan.org/search?dist=XML-SAX
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5.8.2
15BuildRequires: perl-XML-NamespaceSupport
16Requires: perl >= 5.8.2
17Requires: perl-XML-NamespaceSupport
18#Requires(post): perl-XML-LibXML
19#Requires(preun): perl-XML-LibXML
20
21%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
22# Filter unwanted Requires: perl-XML-SAX has some poorly-structured
23#                           packages that confuse RPM.
24%define __find_requires %{SOURCE1}
25
26# Filter unwanted Provides: perl-XML-SAX should not Provide an
27#                           unversioned perl(XML::SAX) along with the
28#                           versioned one
29%define __find_provides %{SOURCE2}
30%else
31%define __perl_requires %{SOURCE1}
32%endif
33
34
35
36%description
37XML::SAX consists of several framework classes for using and building
38Perl SAX2 XML parsers, filters, and drivers. It is designed around the
39need to be able to "plug in" different SAX parsers to an application
40without requiring programmer intervention. Those of you familiar with
41the DBI will be right at home. Some of the designs come from the Java
42JAXP specification (SAX part), only without the javaness.
43
44%prep
45%setup -q -n XML-SAX-%{version}
46
47%build
48%{__perl} Makefile.PL INSTALLDIRS=vendor <<_OPTION_
49N
50_OPTION_
51make OPTIMIZE="$RPM_OPT_FLAGS"
52
53%check
54make test
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%install
60rm -rf $RPM_BUILD_ROOT
61make pure_install DESTDIR=$RPM_BUILD_ROOT
62find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
63find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
64chmod -R u+w $RPM_BUILD_ROOT/*
65
66touch $RPM_BUILD_ROOT%{perl_vendorlib}/XML/SAX/ParserDetails.ini
67
68[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
69
70#find $RPM_BUILD_ROOT%{_prefix} -type f -print |
71#       sed "s@^$RPM_BUILD_ROOT@@g" |
72#       grep -v ^%{_mandir} |
73#       grep -v perllocal.pod |
74#       grep -v "\.packlist" > %{name}.files
75#if [ "$(cat %{name}.files)X" = "X" ] ; then
76#    echo "ERROR: EMPTY FILE LIST"
77#    exit -1
78#fi
79
80%post
81perl -MXML::SAX -e \
82  'XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()' 2>/dev/null
83
84%preun
85if [ $1 -eq 0 ]; then
86  perl -MXML::SAX -e \
87    'XML::SAX->remove_parser(q(XML::SAX::PurePerl))->save_parsers()'
88fi
89
90%files
91%defattr(-,root,root)
92%doc README Changes LICENSE
93%dir %{perl_vendorlib}/XML
94%{perl_vendorlib}/XML/SAX.pm
95%dir %{perl_vendorlib}/XML/SAX
96%{perl_vendorlib}/XML/SAX/*.pm
97%{perl_vendorlib}/XML/SAX/*.pod
98%{perl_vendorlib}/XML/SAX/PurePerl
99%{_mandir}/man3/*3pm*
100%ghost %{perl_vendorlib}/XML/SAX/ParserDetails.ini
101%exclude %{perl_vendorlib}/XML/SAX/placeholder.pl
102
103%changelog
104* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16-3
105- drebuild with perl-5.12.3
106- using __perl_requires macro for VineSeed (vl6)
107
108* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-2
109- added Requires(post,preun): perl-XML-LibXML
110
111* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-1
112- new upstream release
113- built with perl-5.10.0-2
114- added SOURCE1, 2 for avoiding unwanted dependancies
115
116* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.12-0vl2
117- build on perl-5.8.6-0vl1
118
119* Sun Oct 17 2004 Satoshi MACHINO <machino@vinelinux.org> 0.12-0vl1
120- new upstream version
121- updated patch0 to perl-XML-SAX-0.12-makefile.patch
122
123* Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.10-0vl1
124- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.