source: projects/specs/branches/6/p/perl-XML-RSS/perl-XML-RSS-vl.spec @ 521

Revision 521, 1.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
2
3Summary: creates and updates RSS files with Perl
4Name: perl-XML-RSS
5Version: 1.05
6Release: 0vl1
7Copyright: distributable
8Group: Development/Languages
9Source0: http://www.cpan.org/authors/id/E/EI/EISEN/XML-RSS-%{version}.tar.gz
10Url: http://search.cpan.org/search?dist=XML-RSS
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: perl >= 5.004, perl-XML-Parser
14Requires: perl >= 5.004, perl-XML-Parser
15
16%description
17XML-RSS module for perl
18
19%prep
20%setup -q -n XML-RSS-%{version}
21
22%build
23CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL
24make
25
26%clean
27rm -rf $RPM_BUILD_ROOT
28
29%install
30rm -rf $RPM_BUILD_ROOT
31mkdir -p $RPM_BUILD_ROOT%{_prefix}
32make DESTDIR=$RPM_BUILD_ROOT install
33
34find $RPM_BUILD_ROOT%{_prefix} -type f -print |
35        sed "s@^$RPM_BUILD_ROOT@@g" |
36        grep -v ^%{_mandir} |
37        grep -v perllocal.pod |
38        grep -v "\.packlist" > %{name}.files
39if [ "$(cat %{name}.files)X" = "X" ] ; then
40    echo "ERROR: EMPTY FILE LIST"
41    exit -1
42fi
43
44%files -f %{name}.files
45%defattr(-,root,root)
46%doc README Changes TODO examples
47%{_mandir}/man?/*
48%dir %{perl_sitelib}/XML
49
50%changelog
51* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 1.05-0vl1
52- new upstream release
53- build on perl-5.8.6-0vl1
54
55* Mon Dec 15 2003 IWAI, Masaharu <iwai@alib.jp> 1.02-0vl1
56- new upstream release
57- add %%{perl_sitelib}/XML directory in %%files
58- add TODO and examples if %%doc dir
59- drop BUGS in %%doc dir: because it lost.
60
61* Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.97-0vl1
62- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.