source: projects/specs/branches/6/p/perl-XML-LibXML/perl-XML-LibXML-vl.spec @ 3153

Revision 3153, 5.2 KB checked in by Takemikaduchi, 13 years ago (diff)

freeglut: add BR and Patch, others: rebuild with perl-5.12.3

Line 
1Summary: Perl interface to the libxml2 library
2Name: perl-XML-LibXML
3# NOTE: also update perl-XML-LibXSLT to the same version, see
4# https://bugzilla.redhat.com/show_bug.cgi?id=469480
5Version: 1.70
6Release: 2%{?_dist_release}
7License: GPL+ or Artistic
8Group: Development/Libraries
9URL: http://search.cpan.org/dist/XML-LibXML/
10Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Requires:       %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
15Requires:       %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
16Requires:       %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18BuildRequires: perl >= 2:5.8.0
19BuildRequires: perl(XML::NamespaceSupport)
20BuildRequires: perl(XML::SAX)
21BuildRequires:  perl(ExtUtils::MakeMaker), perl(Test::More)
22BuildRequires: libxml2-devel
23
24Provides:       perl-XML-LibXML-Common = %{version}
25Obsoletes:      perl-XML-LibXML-Common <= 0.13
26
27%description
28This module implements a Perl interface to the GNOME libxml2 library
29which provides interfaces for parsing and manipulating XML files. This
30module allows Perl programmers to make use of the highly capable
31validating XML parser and the high performance DOM implementation.
32
33%prep
34%setup -q -n XML-LibXML-%{version}
35
36%build
37%__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
38%__make %{?_smp_mflags}
39
40%install
41%__rm -rf $RPM_BUILD_ROOT
42%__make install \
43  PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
44  INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
45find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
46  -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
47find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
48%__chmod -R u+w $RPM_BUILD_ROOT/*
49
50for i in Changes; do
51  /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
52done
53
54%check
55%__make test
56
57%clean
58%__rm -rf $RPM_BUILD_ROOT
59
60%triggerin -- perl-XML-SAX
61for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
62  perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
63    2>/dev/null || :
64done
65
66%preun
67if [ $1 -eq 0 ] ; then
68  for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
69    perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
70      2>/dev/null || :
71  done
72fi
73
74%files
75%defattr(-,root,root,-)
76%doc Changes LICENSE README
77%{perl_vendorarch}/auto/XML
78%{perl_vendorarch}/XML
79%{_mandir}/man3/*.3*
80
81%changelog
82* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
83- rebuild with perl-5.12.3
84
85* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
86- new upstream release
87
88* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
89- Mass rebuild with perl-5.12.0
90
91* Fri Jan  8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
92- remove BR XML::LibXML::Common
93
94* Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
95- corrected version of obsoletes
96
97* Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
98- 541605 this package now contains XML::LibXML::Common
99
100* Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
101- update to fix 539102
102
103* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
105
106* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
108
109* Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
110- update to 1.69
111
112* Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
113- Supress warning about nonexistent file in perl-XML-SAX install trigger
114
115* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
116- new upsteream release
117- built with perl-5.10.0-2
118- changed Group to Development/Libraries
119
120* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
121- changed Group to Development/Languages
122- rebuilt with libxml2-2.6.26
123
124* Sun Apr  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
125- rebuilt for Vine Linux
126
127* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
128- bump again for double-long bug on ppc(64)
129
130* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
131- rebuilt for new gcc4.1 snapshot and glibc changes
132
133* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
134- rebuild for new perl-5.8.8
135
136* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
137- rebuilt for new gcc
138
139* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
140- rebuilt for new gcj
141
142* Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
143- rebuild
144
145* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
146- #121168
147- Update to 1.58.
148- Require perl(:MODULE_COMPAT_*).
149- Handle ParserDetails.ini parser registration.
150- BuildRequires libxml2-devel.
151- Own installed directories.
152
153* Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
154- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.