source: projects/specs/branches/6/p/perl-XML-Grove/perl-XML-Grove-vl.spec @ 3739

Revision 3739, 2.9 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define _use_internal_dependency_generator 0
2
3%define module  XML-Grove
4
5Summary: A Perl module providing simple access to the information set of parsed XML, HTML, or SGML instances.
6Name: perl-%{module}
7Version: 0.46alpha
8Release: 27%{?_dist_release}
9License: distributable
10Group: Development/Libraries
11Source0: %{module}-%{version}.tar.bz2
12URL: http://search.cpan.org/~kmacleod/XML-Grove/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: perl >= 5.8.2
15BuildRequires: perl-libxml-perl
16
17BuildArch: noarch
18
19%description
20XML::Grove is a tree-based object model for accessing the information
21set of parsed or stored XML, HTML, or SGML instances. XML::Grove
22objects are Perl hashes and arrays where you access the properties of
23the objects using normal Perl syntax.
24
25%prep
26%setup -q -n %{module}-%{version}
27
28%build
29CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
30make
31#make test || /bin/true
32
33%clean
34rm -rf $RPM_BUILD_ROOT
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39make DESTDIR=$RPM_BUILD_ROOT install
40
41[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
42
43find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
44
45find $RPM_BUILD_ROOT/usr -type f -print |
46        sed "s@^$RPM_BUILD_ROOT@@g" |
47        grep -v perllocal.pod |
48        grep -v "\.packlist" > XML-Grove-%{version}-filelist
49if [ "$(cat XML-Grove-%{version}-filelist)X" = "X" ] ; then
50    echo "ERROR: EMPTY FILE LIST"
51    exit -1
52fi
53
54%files -f XML-Grove-%{version}-filelist
55%defattr(-,root,root)
56
57%changelog
58* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.46alpha-27
59- rebuild with perl-5.12.3
60
61* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46alpha-26
62- applied new versioning policy
63- rebuilt with perl-5.10.0
64- changed Group to Development/Libraries
65
66* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46alpha-25vl6
67- changed Group to Development/Languages
68
69* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.46alpha-25vl5
70- build on perl-5.8.6-0vl1
71
72* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 0.46alpha-25vl4
73- rebuilt on perl-5.8.2
74
75* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 0.46alpha-25vl3
76- rebuilt on perl-5.8.1
77
78* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 0.46alpha-25vl2
79- build on perl-5.8.0
80
81* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 0.46alpha-25vl1
82- build for VineLinux
83
84* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
85- automated release bump and build
86
87* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
88- properly claim directories owned by package so they are removed when package is removed
89
90* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com>
91- add internal provides.
92
93* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
94- automated rebuild
95
96* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 0.46alpha-2
97- imported from mandrake
98
99* Mon Jun 18 2001 Till Kamppeter <till@mandrakesoft.com> 0.46alpha-1mdk
100- Newly introduced for Foomatic.
101
Note: See TracBrowser for help on using the repository browser.