source: projects/specs/branches/6/p/perl-Text-CSV_XS/perl-Text-CSV_XS-vl.spec @ 3736

Revision 3736, 2.5 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
3
4# Provide perl-specific find-{provides,requires}.
5%define __find_provides /usr/lib/rpm/find-provides.perl
6%define __find_requires /usr/lib/rpm/find-requires.perl
7
8Summary: Text-CSV_XS module for perl
9Name: perl-Text-CSV_XS
10Version: 0.65
11Release: 2%{?_dist_release}
12License: Artistic/GPL
13Group: Development/Libraries
14Source0: http://www.cpan.org/authors/id/JWIED/Text-CSV_XS-%{version}.tgz
15URL: http://search.cpan.org/~jwied/Text-CSV_XS/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: perl >= 5.8.6
18Requires: perl >= 5.8.6
19
20%description
21Text-CSV_XS module for perl
22
23%prep
24%setup -q -n Text-CSV_XS-%{version}
25
26%build
27CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
28make
29
30%check
31make test
32
33%clean
34rm -rf $RPM_BUILD_ROOT
35
36%install
37rm -rf $RPM_BUILD_ROOT
38mkdir -p $RPM_BUILD_ROOT%{_prefix}
39make DESTDIR=$RPM_BUILD_ROOT install
40
41find $RPM_BUILD_ROOT%{_prefix} -type f -print |
42        sed "s@^$RPM_BUILD_ROOT@@g" |
43        grep -v ^%{_mandir} |
44        grep -v perllocal.pod |
45        grep -v "\.packlist" > %{name}.files
46if [ "$(cat %{name}.files)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51# remove unnecessary files.
52%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_archlib}/perllocal.pod
53%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_vendorarch}/auto/Text/CSV_XS/.packlist
54
55%files -f %{name}.files
56%defattr(-,root,root)
57%doc README ChangeLog
58%{_mandir}/*/*
59%dir %{perl_vendorarch}/auto/Text/CSV_XS
60
61
62%changelog
63* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-2
64- rebuild with perl-5.12.3
65
66* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.65-1
67- new upstream release
68
69* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.34-1vl5
70- applied new versioning policy
71- built with perl-5.10.0
72
73* Sat Jan  5 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.34-0vl1
74- rebuild for VineSeed.
75  * Sat Jan  5 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.34-0vl0
76  - new upstream release.
77
78* Sat Jan  5 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.34-0vl0
79- new upstream release.
80
81* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.23-0vl3
82- changed Group to Development/Libraries
83
84* Thu Sep  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.23-0vl2
85- rebuild with perl 5.8.6
86- use vendor_perl
87- updated URL
88- s/Copyright/License/
89
90* Sat Apr 13 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.23-0vl1
91- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.