source: projects/specs/branches/6/p/perl-Test-Unit/perl-Test-Unit-vl.spec @ 3739

Revision 3739, 2.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1Summary: a unit testing interface for Perl
2Name: perl-Test-Unit
3Version: 0.25
4Release: 2%{?_dist_release}
5License: Perl's
6Group: Development/Libraries
7Source0: http://prdownloads.sourceforge.net/perlunit/Test-Unit-%{version}.tar.gz
8Url: http://perlunit.sourceforge.net/
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 5.004
12BuildRequires: perl-Class-Inner
13BuildRequires: perl-Devel-Symdump
14BuildRequires: perl-Error
15Requires: perl >= 5.004
16Requires: perl-Error
17Requires: perl-Devel-Symdump
18Requires: perl-Class-Inner
19Requires: perl-Tk
20BuildArch: noarch
21
22%description
23Test::Unit is the procedural style interface to a sophisticated
24unit testing framework for Perl that is derived from the JUnit
25testing framework for Java by Kent Beck and Erich Gamma.
26
27%prep
28%setup -q -n Test-Unit-%{version}
29
30%build
31CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
32make
33
34%install
35rm -rf $RPM_BUILD_ROOT
36mkdir -p $RPM_BUILD_ROOT%{_prefix}
37make DESTDIR=$RPM_BUILD_ROOT install
38
39find $RPM_BUILD_ROOT%{_prefix} -type f -print |
40        sed "s@^$RPM_BUILD_ROOT@@g" |
41        grep -v ^%{_mandir} |
42        grep -v perllocal.pod |
43        grep -v "\.packlist" > %{name}.files
44if [ "$(cat %{name}.files)X" = "X" ] ; then
45    echo "ERROR: EMPTY FILE LIST"
46    exit -1
47fi
48
49%check
50make test
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files -f %{name}.files
56%defattr(-,root,root)
57%doc Changes README doc examples *.pl AUTHORS ChangeLog
58%{_mandir}/*/*
59%dir %{perl_vendorlib}/Test
60%dir %{perl_vendorlib}/Test/Unit
61%dir %{perl_vendorlib}/Test/Unit/Assertion
62%dir %{perl_vendorlib}/Test/Unit/Runner
63
64%changelog
65* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-2
66- rebuild with perl-5.12.3
67
68* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-1vl5
69- applied new versioning policy
70- added BuildRequires: perl-Class-Inner, perl-Devel-Symdump, perl-Error
71
72* Thu Feb 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-0vl1
73- updated to 0,25
74- changed Group to Development/Libraires
75- added Requires: perl-Tk
76
77* Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.24-0vl1
78- version up to 0.24
79- replace Copyright tag with License tag
80- clarify the License
81- update Requires:
82    add perl-Error, perl-Devel-Symdump and perl-Class-Inner
83
84* Fri Apr  5 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.14-0vl1
85- first release for Vine Linux
86
Note: See TracBrowser for help on using the repository browser.