source: projects/specs/branches/6/p/perl-RDF-Core/perl-RDF-Core-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An object oriented Perl modules for handling tasks related to RDF
2Name: perl-RDF-Core
3Version: 0.51
4Release: 1%{?_dist_release}
5License: MPL or GPL
6Group: Development/Libraries
7Source0: RDF-Core-%{version}.tar.gz
8URL: http://www.cpan.org/dist/RDF-Core/
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl >= 5.004, perl-URI >= 1.03, perl-XML-Parser >= 2.30
13BuildRequires: perl-DBI >= 1.14
14Requires: perl >= 5.004
15Requires: perl-URI >= 1.03
16Requires: perl-XML-Parser >= 2.30
17Requires: perl-DBI >= 1.14
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23RDF::Core is a pure perl implementation of RDF storage, parser, serializer
24and query.
25
26The storage functionality is basic - store, delete, query statements, where
27query means ask about existence or count or retrieve statements conforming
28given mask of (subject, predicate, object). Three storages are available -
29in memory, file (DB_File) and DBMS (PostgreSQL).
30
31The parser supports full RDF/XML syntax including aboutEach attribute (though
32it became obsolete). The serializer attempts to preserve anonymous nodes and
33to compact xml a bit grouping statements with common subject.
34
35The query language is rather focused on resources than on statements. The
36typical pattern is me->neighbor->child->age to express neighbour's children's
37age, not (me,neighbour, him) && (him, child, it) && (it, age, value).
38It contains some shortcuts to express things, that are (possibly) expressed
39often, like object->rdf:type = someClass. Functions are another enhancement
40of the language. They can be used instead of resource or property. Functions
41are implemented in a separated library, so that it's easy to create new or
42modify existing ones.
43
44Original creator of RDF::Core is Ginger Alliance (www.gingerall.com).
45
46%prep
47%setup -q -n RDF-Core-%{version}
48
49%build
50CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
51make
52
53%install
54rm -rf %{buildroot}
55mkdir -p %{buildroot}%{_prefix}
56make DESTDIR=%{buildroot} install
57
58rm -f %{buildroot}%{perl_vendorlib}/perllocal.pod
59rm -f %{buildroot}%{perl_vendorarch}/auto/RDF/Core/.packlist
60
61find %{buildroot}%{_prefix} -type f -print |
62        sed "s@^%{buildroot}@@g" |
63        grep -v ^%{_mandir} > %{name}.files
64if [ "$(cat %{name}.files)X" = "X" ] ; then
65    echo "ERROR: EMPTY FILE LIST"
66    exit -1
67fi
68
69%check
70make test
71
72%clean
73rm -rf %{buildroot}
74
75
76%files -f %{name}.files
77%defattr(-,root,root)
78%doc Changes README dbmodel doc
79%{_mandir}/*/*
80%dir %{perl_vendorlib}/RDF
81%dir %{perl_vendorlib}/RDF/Core
82%dir %{perl_vendorlib}/RDF/Core/Enumerator
83%dir %{perl_vendorlib}/RDF/Core/Model
84%dir %{perl_vendorlib}/RDF/Core/Storage
85
86%changelog
87* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.51-1
88- applied new versioning policy
89
90* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.51-0vl1
91- new upstream release
92- changed Group to Development/Libraries
93
94* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 0.31-0vl1
95- new upstream release
96- build on perl-5.8.6-0vl1
97
98* Sun Jul  6 2003 IWAI Masaharu <iwai@alib.jp> 0.30-0vl1
99- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.