source: projects/specs/branches/6/p/perl-Parse-RecDescent/perl-Parse-RecDescent-vl.spec @ 1566

Revision 1566, 5.7 KB checked in by munepi, 14 years ago (diff)

NEW: latexml, perl-Parse-RecDescent?, perl-XML-LibXSLT; update: perl-XML-LibXML

Line 
1Name:           perl-Parse-RecDescent
2Version:        1.964
3Release:        1%{?_dist_release}
4Summary:        Parse-RecDescent Perl module
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Parse-RecDescent/
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Parse-RecDescent-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12BuildRequires:  perl(ExtUtils::MakeMaker), perl(version), perl(Test::More)
13BuildRequires:  perl(Test::Pod)
14BuildRequires:  perl(Text::Balanced)
15
16Distribution:   Vine
17Vendor:         Project Vine
18Packager:       munepi
19
20%{?perl_default_filter}
21
22%description
23Parse::RecDescent incrementally generates top-down recursive-descent
24text parsers from simple yacc-like grammar specifications. It
25provides:
26    * Regular expressions or literal strings as terminals (tokens),
27    * Multiple (non-contiguous) productions for any rule,
28    * Repeated and optional subrules within productions,
29    * Full access to Perl within actions specified as part of the
30      grammar,
31    * Simple automated error reporting during parser generation and
32      parsing,
33    * The ability to commit to, uncommit to, or reject particular
34      productions during a parse,
35    * The ability to pass data up and down the parse tree ("down" via
36      subrule argument lists, "up" via subrule return values)
37    * Incremental extension of the parsing grammar (even during a
38      parse),
39    * Precompilation of parser objects,
40
41User-definable reduce-reduce conflict resolution via "scoring" of
42matching productions.
43
44
45%prep
46%setup -q -n Parse-RecDescent-%{version}
47
48chmod a-x demo/* tutorial/*
49%{__perl} -pi -e 's|^#!\s?/usr/local/bin/perl\b|#!%{__perl}|' demo/*
50%{__perl} -pi -e 's|^#!\s?/opt/local/bin/perl5\.10\.0\b|#!%{__perl}|' demo/*
51for f in Changes demo/demo_dot.pl; do
52  iconv -f iso-8859-1 -t utf-8 < "$f" > "${f}_" && %__mv -f "${f}_" "$f"
53done
54
55
56%build
57%{__perl} Makefile.PL INSTALLDIRS=vendor
58%__make %{?_smp_mflags}
59
60
61%install
62%__rm -rf $RPM_BUILD_ROOT
63%__make pure_install DESTDIR=$RPM_BUILD_ROOT
64find $RPM_BUILD_ROOT -type f -name .packlist -exec %__rm -f {} ';'
65find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
66%__chmod -R u+w $RPM_BUILD_ROOT/*
67
68
69%check
70%__make test
71
72
73%clean
74%__rm -rf $RPM_BUILD_ROOT
75
76
77%files
78%defattr(-,root,root,-)
79%{perl_vendorlib}/Parse/
80%{_mandir}/man3/*.3*
81%doc Changes README demo/ tutorial/
82
83
84%changelog
85* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.964-1
86- initial build
87
88* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.964-2
89- Mass rebuild with perl-5.12.0
90
91* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.964-1
92- update, fix previous issue and https://rt.cpan.org/Public/Bug/Display.html?id=53948
93
94* Tue Feb 16 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.963-2
95- apply upstream patch https://rt.cpan.org/Public/Bug/Display.html?id=54457
96  which should fix problems with rebuilds of other modules
97
98* Tue Feb  9 2010 Paul Howarth <paul@city-fan.org> 1.963-1
99- update to 1.963 (fix subtle bug in leftop and rightop due to removal of $&)
100- recode Changes as utf-8
101- more script interpreter fixes
102
103* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.962.2-1
104- updated for latest GA SQL::Translator
105- add default filtering
106- auto-update to 1.962.2 (by cpan-spec-update 0.01)
107- added a new br on perl(Text::Balanced) (version 0)
108
109* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-3
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
111
112* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
114
115* Mon Feb  2 2009 Stepan Kasal <skasal@redhat.com> - 1.96-1
116- new upstream version
117
118* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-5
119- Rebuild for perl 5.10 (again)
120
121* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-4
122- rebuild for new perl
123
124* Wed Nov 14 2007 Robin Norwood <rnorwood@redhat.com> - 1.95.1-3
125- Apply fixes from package review:
126  - Remove BR: perl
127  - Use iconv to convert file to utf-8
128  - Include BR: perl(Test::Pod)
129  - Fix old changelog entry
130- Resolves: bz#226274
131
132* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-2
133- add BR: perl(version), perl(Test::More)
134
135* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-1
136- bump to 1.95.1
137- correct license tag (now under perl license)
138- add BR: perl(ExtUtils::MakeMaker)
139
140* Fri Jul 20 2007 Robin Norwood <rnorwood@redhat.com> - 1.94-6.fc8
141- Bring fixes from EPEL build into F8
142- Fix minor specfile issues
143- Package the docs as well
144
145* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.94-5.2.1
146- rebuild
147
148* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.94-5.2
149- rebuild for new perl-5.8.8
150
151* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
152- rebuilt for new gcc
153
154* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
155- rebuilt for new gcj
156
157* Thu Apr 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.94-5
158- #155620
159- Bring up to date with current Fedora.Extras perl spec template.
160
161* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.94-4
162- rebuild
163
164* Tue Feb 17 2004 Chip Turner <cturner@redhat.com> 1.94-2
165- fix rm to not be interactive (bz115997)
166
167* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1.94-1
168- update to 1.94
169
170* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
171- automated release bump and build
172
173* Sat Jul 20 2002 Chip Turner <cturner@localhost.localdomain>
174- remove Text::Balanced modules since they are now in core perl
175
176* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
177- description update
178
179* Fri Jun 07 2002 cturner@redhat.com
180- Specfile autogenerated
Note: See TracBrowser for help on using the repository browser.