source: projects/specs/branches/6/p/perl-Jcode/perl-Jcode-vl.spec @ 3668

Revision 3668, 3.1 KB checked in by iwaim, 13 years ago (diff)

perl-Jcode-2.07-1

Line 
1%define real_name Jcode
2
3Summary: a Perl extension interface to convert Japanese text
4Summary(ja): さまざまな日本語文字コードを Perl で扱うための Module
5Name: perl-Jcode
6Version: 2.07
7Release: 1%{?_dist_release}
8License: Free (the same terms as Perl itself)
9Group: Development/Libraries
10Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
11Requires: perl >= 5.8.1
12BuildRequires: perl >= 5.8.1
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15
16%description
17This is a Perl module for using Japanese charset.
18
19%description -l ja
20さまざまな日本語文字コードを Perl で扱うための Module
21
22%prep
23%setup -q -n %{real_name}-%{version}
24
25%build
26perl Makefile.PL INSTALLDIRS=vendor
27make
28
29%install
30rm -rf %{buildroot}
31make install DESTDIR=%{buildroot}
32             
33rm -f %{buildroot}%{perl_vendorarch}/mac_install.pl
34rm -f %{buildroot}%{perl_vendorarch}/win_install.pl
35
36
37find $RPM_BUILD_ROOT%{_libdir} -type f -print |
38         sed "s@^$RPM_BUILD_ROOT@@g" |
39         grep -v perllocal.pod |
40         grep -v "\.packlist" > %{name}.files
41if [ "$(cat %{name}.files)X" = "X" ] ; then
42    echo "ERROR: EMPTY FILE LIST"
43    exit -1
44fi
45
46perllocalfile=`find %{buildroot} -name perllocal.pod`
47echo "mv $perllocalfile ."
48mv $perllocalfile .
49
50%clean
51rm -rf %{buildroot}
52
53%check
54make test
55
56%files -f %{name}.files
57%defattr(-,root,root)
58%doc Changes MANIFEST README perllocal.pod
59%dir %{perl_vendorlib}/Jcode
60#dir %{perl_vendorarch}/Jcode/Unicode
61#dir %{perl_vendorarch}/auto/Jcode
62#dir %{perl_vendorarch}/auto/Jcode/Unicode
63%{_mandir}/man3/*
64
65%changelog
66* Sat Apr 23 2011 IWAI, Masaharu <iwai@alib.jp> 2.07-1
67- new upstream release
68- update {,Build}Requires perl version: 5.8.1+
69
70* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-2
71- spec in UTF-8
72
73* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
74- applied new versioning policy
75
76* Fri Feb 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-0vl1
77- new upstream release
78- changed Group to Development/Libraries
79- changed noarch
80
81* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 0.88-0vl1
82- build on perl-5.8.6-0vl1
83
84* Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.83-0vl4
85- build with perl-5.8.2
86
87* Thu May  8 2003 IWAI Masaharu <iwai@alib.jp> 0.83-0vl3
88- drop scripts for installing on the MS Windows and MacOS
89
90* Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.83-0vl2
91- fixed install dir of perllocal.pod
92
93* Wed Apr 16 2003 IWAI Masaharu <iwai@alib.jp> 0.83-0vl1
94- update to 0.83
95- build with perl-5.8.0
96- eliminate perl-MIME-Base64 in {Build,}Requires
97
98* Sat Feb 15 2003 IWAI Masaharu <iwai@alib.jp> 0.82-0vl1
99- update to 0.82
100
101* Sun May 19 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.80-0vl1
102- updated to 0.80
103- HISTORY -> Changes
104
105* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
106- 0.75-0vl2: was ported to VineSeedPlus with minor spec fixes
107
108* Tue Jul 24 2001 Yasuhide OOMORI <dasen@icntv.ne.jp>
109- updated to 0.75
110
111* Thu Jun 14 2001 Yasuhide OOMORI <dasen@icntv.ne.jp>
112- fixed Copyright.
113
114* Thu Jun 14 2001 Yasuhide OOMORI <dasen@icntv.ne.jp>
115- first version of rpm.
116
117# end of file
Note: See TracBrowser for help on using the repository browser.