source: projects/specs/branches/6/p/perl-IP-Country/perl-IP-Country-vl.spec @ 3739

Revision 3739, 3.5 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define real_name IP-Country
2
3Summary: Classes for fast lookup of country codes from IP addresses for Perl
4Name: perl-IP-Country
5Version: 2.26
6Release: 2%{_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/dist/IP-Country/
10
11Source: http://search.cpan.org/CPAN/authors/id/N/NW/NWETTERS/%{real_name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildArch: noarch
15BuildRequires: perl >= 0:5.00503
16BuildRequires: perl(Geography::Countries)
17Requires: perl >= 0:5.00503
18
19%description
20Finding the home country of a client using only the IP address can be difficult.
21Looking up the domain name associated with that address can provide some help,
22but many IP address are not reverse mapped to any useful domain, and the
23most common domain (.com) offers no help when looking for country.
24
25This module comes bundled with a database of countries where various IP addresses
26have been assigned. Although the country of assignment will probably be the
27country associated with a large ISP rather than the client herself, this is
28probably good enough for most log analysis applications, and under test has proved
29to be as accurate as reverse-DNS and WHOIS lookup.
30
31%prep
32%setup -n %{real_name}-%{version}
33
34%build
35CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS=vendor
36make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40make install DESTDIR=$RPM_BUILD_ROOT
41
42find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
43
44find $RPM_BUILD_ROOT%{_prefix} -type f -print |
45        sed "s@^$RPM_BUILD_ROOT@@g" |
46        grep -v ^%{_bindir} |
47        grep -v ^%{_mandir} |
48        grep -v "\.packlist" > %{name}.files
49if [ "$(cat %{name}.files)X" = "X" ] ; then
50    echo "ERROR: EMPTY FILE LIST"
51    exit -1
52fi
53
54
55%check
56make test
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files -f %{name}.files
62%defattr(-, root, root, 0755)
63%doc CHANGES MANIFEST README
64%{_bindir}/ip2cc
65%{_mandir}/man1/ip2cc.1*
66%{_mandir}/man3/*.3*
67%dir %{perl_vendorlib}/IP
68
69%changelog
70* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26-2
71- rebuild with perl-5.12.3
72
73* Mon Jun 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.26-1
74- new upstream release
75- remove BR: perl(Geography::Countries)
76
77* Mon May 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.24-1
78- new upstream release
79
80* Mon May 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.23-1
81- rebuild with perl 5.10
82- new versioning policy
83
84* Sun Feb 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.23-0vl1
85- new upstream release
86- change group to Development/Libraries
87
88* Tue Oct 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl3
89- change group to Development/Languages
90
91* Mon Oct 16 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl2
92- 1st release for VinePlus 4.0
93- change install dir (site -> vendor)
94- fix change log typo
95
96* Sun Oct 15 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl1
97- 1st release for VinePlus 3.2
98- change install dir (vendor -> site)
99- remove smp flag in make section
100
101* Mon May 29 2006 Dag Wieers <dag@wieers.com> - 2.21-1
102- Updated to release 2.21.
103
104* Sat Jun 18 2005 Dries Verachtert <dries@ulyssis.org> - 2.20-1
105- Updated to release 2.20.
106
107* Sat Nov 06 2004 Dag Wieers <dag@wieers.com> - 2.18-1
108- Updated to release 2.18.
109
110* Fri Jan 02 2004 Dag Wieers <dag@wieers.com> - 2.17-0
111- Updated to release 2.17.
112
113* Mon Jul 14 2003 Dag Wieers <dag@wieers.com> - 2.14-0
114- Updated to release 2.14.
115
116* Sat Feb 01 2003 Dag Wieers <dag@wieers.com> - 2.08-0
117- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.