source: projects/specs/branches/6/p/perl-IO-String/perl-IO-String-vl.spec @ 3739

Revision 3739, 2.9 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1Name:           perl-IO-String
2Version:        1.08
3Release:        2%{?_dist_release}
4
5Summary:        Emulate file interface for in-core strings
6Group:          Development/Libraries
7License:        GPL or Artistic
8URL:            http://search.cpan.org/dist/IO-String/
9Source0:        http://www.cpan.org/authors/id/G/GA/GAAS/IO-String-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildArch:      noarch
13BuildRequires:  perl >= 5.6.1
14Requires:  perl >= 5.6.1
15
16%description
17The "IO::String" module provides the "IO::File" interface for in-core
18strings.  An "IO::String" object can be attached to a string, and
19makes it possible to use the normal file operations for reading or
20writing data, as well as for seeking to various locations of the
21string.  This is useful when you want to use a library module that
22only provides an interface to file handles on data that you have in a
23string variable.
24
25Note that perl-5.8 and better has built-in support for "in memory"
26files, which are set up by passing a reference instead of a filename
27to the open() call. The reason for using this module is that it makes
28the code backwards compatible with older versions of Perl.
29
30
31%prep
32%setup -q -n IO-String-%{version}
33
34
35%build
36perl Makefile.PL INSTALLDIRS=vendor
37make %{?_smp_mflags}
38
39%install
40rm -rf $RPM_BUILD_ROOT
41make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
42#find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
43#find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
44#chmod -R u+w $RPM_BUILD_ROOT/*
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT/usr -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v %{_mandir} |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > IO-String-%{version}-filelist
53if [ "$(cat IO-String-%{version}-filelist)X" = "X" ] ; then
54    echo "ERROR: EMPTY FILE LIST"
55    exit -1
56fi
57
58
59%check || :
60make test
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%files -f IO-String-%{version}-filelist
67%defattr(-,root,root,-)
68%doc Changes README
69%dir %{perl_vendorlib}/IO/
70#{perl_vendorlib}/IO/*
71%{_mandir}/man3/*.3*
72
73
74%changelog
75* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.08-2
76- rebuilt with perl-5.12.3
77
78* Tue Nov  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-1vl5
79- applied new versioning policy
80- rebuilt with perl 5.10.0
81
82* Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
83- new upstream release
84- changed Group to Development/Libraries
85
86* Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
87- new upstream release
88- changed Group to Development/Libraries
89
90* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
91- rebuilt for Vine
92
93* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
94- rebuilt
95
96* Wed Nov 24 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-1
97- Update to 1.06.
98
99* Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
100- First build.
Note: See TracBrowser for help on using the repository browser.