source: projects/specs/branches/6/p/perl-HTML-Template/perl-HTML-Template-vl.spec @ 3229

Revision 3229, 3.7 KB checked in by iwaim, 13 years ago (diff)

perl-HTML-Template-2.9-3

Line 
1%define rel 3
2
3Summary: a Perl module to use HTML Templates
4Name: perl-HTML-Template
5Version: 2.9
6Release: %{rel}%{?_dist_release}
7License: GPL/Artistic
8Group: Development/Libraries
9Source0: http://www.cpan.org/authors/id/S/SA/SAMTREGAR/HTML-Template-%{version}.tar.gz
10Url: http://search.cpan.org/search?dist=HTML-Template
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: perl >= 5.004
13Requires: perl >= 5.004
14BuildArch: noarch
15AutoReq: false
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21This module attempts make using HTML templates simple and natural.
22It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
23<TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>.  The file
24written with HTML and these new tags is called a template.  It is
25usually saved separate from your script - possibly even created by
26someone else!  Using this module you fill in the values for the
27variables, loops and branches declared in the template.  This allows
28you to seperate design - the HTML - from the data, which you generate
29in the Perl script.
30
31%description -l ja
32このモジュールは HTML テンプレートを使うことを簡単に、自然にしようとし
33ます。これは標準の HTML をいくつかの新しいHTML風のタグ - <TMPL_VAR>,
34<TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF>, <TMPL_ELSE>, <TMPL_UNLESS> で拡
35張します。 HTML とこれらの新しいタグで書かれたファイルはテンプレートと
36呼ばれます。これは通常スクリプトとは別に保存されます - もしかしたら他の
37誰かによって作成されることさえあるかもしれません! このモジュールを使っ
38て、変数のための値を埋めたり、テンプレートで宣言されたループや分岐をお
39こないます。これにより Perl スクリプトで作成されるデータからデザイン
40- HTML - を分けることが出来ます。
41
42%prep
43%setup -q -n HTML-Template-%{version}
44
45%build
46CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
47#PREFIX=%{buildroot}%{_prefix}
48make
49
50%install
51rm -rf $RPM_BUILD_ROOT
52mkdir -p $RPM_BUILD_ROOT%{_prefix}
53make DESTDIR=$RPM_BUILD_ROOT install
54
55[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
56
57find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
58
59find $RPM_BUILD_ROOT%{_prefix} -type f -print |
60        sed "s@^$RPM_BUILD_ROOT@@g" |
61        grep -v ^%{_mandir} |
62        grep -v perllocal.pod |
63        grep -v "\.packlist" > %{name}.files
64if [ "$(cat %{name}.files)X" = "X" ] ; then
65    echo "ERROR: EMPTY FILE LIST"
66    exit -1
67fi
68
69%check
70make test
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files -f %{name}.files
77%defattr(-,root,root)
78%doc ANNOUNCE Changes FAQ README scripts templates
79%{_mandir}/*/*
80%dir %{perl_vendorlib}/HTML
81
82%changelog
83* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 2.9-3vl6
84- build with perl 5.12.3
85- drop defined perl_vendorlib macro
86- add Vendor and Distribution tags
87- fix typo in changelog 2.9-{1,2}
88
89* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.9-2
90- spec in utf-8
91
92* Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 2.9-1
93- rebuild with perl-5.10.0-1
94
95* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-0vl1
96- new upstream release
97- changed Group to Development/Libraries
98
99* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-0vl2
100- added Japanese description from VinePlus/3.2 package
101- added Autoreq: false
102- installed perl modules to vendor_perl
103
104* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 2.7-0vl1
105- new upstream release
106- built with perl-5.8.6
107
108* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 2.6-0vl1
109- build with perl-5.8.0
110- version up to 2.6
111
112* Mon Apr 29 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5-0vl1
113- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.