source: projects/specs/branches/6/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 3216

Revision 3216, 5.7 KB checked in by iwaim, 13 years ago (diff)

perl-HTML-Parser-3.68-2

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
4%define __find_provides /usr/lib/rpm/find-provides.perl
5%define __find_requires /usr/lib/rpm/find-requires.perl
6%endif
7
8%define rel 2
9
10Summary: A Perl module for parsing HTML.
11Summary(ja): HTML を解析するための Perl モジュール
12Name: %{name}
13Version: 3.68
14Release: %{rel}%{?_dist_release}
15License: GPL or Artistic
16Group: Development/Libraries
17Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
18Url: http://search.cpan.org/~gaas/HTML-Parser/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
21BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
22Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28The HTML-Parser module for perl to parse and extract information from
29HTML documents, including the HTML::Entities, HTML::HeadParser,
30HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
31
32%prep
33%setup -q -n %{real_name}-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41# make install
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT/usr -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v perllocal.pod |
49        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
50if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
51    echo "ERROR: EMPTY FILE LIST"
52    exit -1
53fi
54
55%check
56make test
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files -f perl-HTML-Parser-%{version}-filelist
62%defattr(-,root,root)
63%dir %{perl_vendorarch}/HTML
64%dir %{perl_vendorarch}/auto/HTML
65%dir %{perl_vendorarch}/auto/HTML/Parser
66
67%changelog
68* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-2
69- add directory in files
70
71* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-1
72- new upstream release
73- add Requires: perl(:MODULE_COMPAT_...)
74- defined __find_{provides,requires} with vl4 and vl5 (updated 3.64-2)
75- add Vendor and Distribution tags
76
77* Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
78- undefine __find_provides and __find_requires at VineSeed
79- added Japanese summary
80
81* Sun Nov  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
82- new upstream release with security fix (CVE-2009-3627)
83
84* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
85- build on perl-5.10.0-1vl5
86
87* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
88- new upstream release
89- changed Group to Development/Libraries
90
91* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
92- new upstream release
93- build on perl-5.8.6-0vl1
94- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
95- update Url value
96- using perl_sitearch macro
97
98* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
99- built on perl-5.8.2
100
101* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
102- new upstream version
103- built on perl-5.8.1
104
105* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
106- New upstream version
107- build on perl-5.8.0
108        -- changed Requires, Buildrequires
109 
110* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
111- 3.26-14vl2
112- Fix Requires, Buildrequires
113
114* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
115- 3.26-14vl1
116- first build for Vine Linux
117- add define __find_provides / __find_requires
118- modefy files list (dir)
119
120* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
121- automated release bump and build
122
123* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
124- properly claim directories owned by package so they are removed when package is removed
125
126* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
127- fix for Makefile.PL sometimes prompting for input
128
129* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
130- update to 3.26, move to vendor_perl
131
132* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
133- automated rebuild
134
135* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
136- imported from mandrake. tweaked man path.
137
138* Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
139- 3.25.
140
141* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
142- Fixed distribution tag.
143- Updated Requires.
144- Added an option to %makeinstall.
145
146* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
147- Rebuild against the latest perl.
148
149* Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
150- 3.18.
151
152* Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
153- 3.15.
154
155* Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
156- 3.14.
157
158* Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
159- 3.13.
160
161* Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
162- 3.11.
163
164* Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
165- macroszifications.
166- add doc.
167
168* Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
169- removed perllocal.pod from files.
170- 3.10.
171
172* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
173- update to 3.08
174
175* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
176- Fix build for i486
177- Use %%{_tmppath} for BuildRoot
178
179* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
180- rebuild, new group, cleanup
181
182* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
183- upgrade to 3.05
184
185* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
186- final cleanup for Mandrake 7
187
188* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
189-updated to 3.02
190
191* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
192- bzip2'd sources
193- updated to 2.23
194
195* Tue May 11 1999 root <root@alien.devel.redhat.com>
196- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.