source: projects/specs/branches/6/p/perl-Geography-Countries/perl-Geography-Countries-vl.spec @ 3736

Revision 3736, 2.6 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define real_name Geography-Countries
2
3Summary: Classes for 2-letter, 3-letter, and numerical codes for countries
4Name: perl-Geography-Countries
5Version: 2009041301
6Release: 2%{_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/dist/Geography-Countries/
10
11Source: http://search.cpan.org/CPAN/authors/id/A/AB/ABIGAIL/%{real_name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildArch: noarch
15BuildRequires: perl >= 0:5.00503
16Requires: perl >= 0:5.00503
17Obsoletes: perl(IP::Country) <= 2.08
18
19%description
20This module maps country names, and their 2-letter, 3-letter and
21numerical codes, as defined by the ISO-3166 maintenance agency [1],
22and defined by the UNSD.
23
24%prep
25%setup -n %{real_name}-%{version}
26
27%build
28%{__perl} Makefile.PL INSTALLDIRS=vendor
29%{__make}
30
31%install
32rm -rf %{buildroot}
33make install DESTDIR=$RPM_BUILD_ROOT
34
35find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
36
37find $RPM_BUILD_ROOT%{_prefix} -type f -print |
38        sed "s@^$RPM_BUILD_ROOT@@g" |
39        grep -v ^%{_mandir} |
40        grep -v perllocal.pod |
41        grep -v "\.packlist" > %{name}.files
42if [ "$(cat %{name}.files)X" = "X" ] ; then
43    echo "ERROR: EMPTY FILE LIST"
44    exit -1
45fi
46
47%check
48make test
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files -f %{name}.files
54%defattr(-, root, root, 0755)
55%doc MANIFEST
56%dir %{perl_vendorlib}/Geography
57%{_mandir}/man3/*.3pm*
58#%{perl_vendorlib}/Geography/Countries.pm
59# %dir %{perl_sitelib}/Geography/
60# %{perl_sitelib}/Geography/Countries.pm
61
62%changelog
63* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2009041301-2
64- rebuild with perl-5.12.3
65
66* Mon Jun 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
67- 2009041301-1
68- new upstream release
69
70* Mon May 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.4-5
71- rebuild with perl 5.10
72- new versioning policy
73
74* Sun Feb 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-2vl4
75- change Group to Development/Libraries
76
77* Tue Oct 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.4-2vl3
78- change group to Development/Languages
79
80* Mon Oct 16 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.4-2vl2
81- 1st release for VinePlus 4.0
82- change install dir (site -> vendor)
83- fix changelog typo
84
85* Sun Oct 15 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.4-2vl1
86- 1st release for VinePlus 3.2
87- change install dir (vendor -> site)
88- remove smp flag in make section
89
90* Fri Jan 13 2006 Dag Wieers <dag@wieers.com> - 1.4-2 - 3697+/dries
91- Cosmetic cleanup.
92
93* Fri Jan 02 2004 Dag Wieers <dag@wieers.com> - 1.4-1
94- Obsolete older perl-IP-Country package.
95
96* Wed Dec 03 2003 Dag Wieers <dag@wieers.com> - 1.4-0
97- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.