source: projects/specs/branches/6/p/perl-GSSAPI/perl-GSSAPI-vl.spec @ 3736

Revision 3736, 1.7 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2
3Summary: Perl extension providing access to the GSSAPIv2 library
4Name: perl-GSSAPI
5Version: 0.26
6Release: 2%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/~gbarr/Authen-SASL/
10Source0: GSSAPI-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12#BuildArch: noarch
13BuildRequires: krb5-devel
14BuildRequires: perl-Test-Pod
15BuildRequires: perl-Test-Pod-Coverage
16Requires: perl
17
18%description
19This module gives access to the routines of the GSSAPI library, as
20described in rfc2743 and rfc2744 and implemented by the Kerberos-1.2
21distribution from MIT.
22
23%prep
24%setup -q -n GSSAPI-%{version}
25
26%build
27CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
28make OPTIMIZE="%{optflags}"
29
30%install
31rm -rf $RPM_BUILD_ROOT
32make install DESTDIR=$RPM_BUILD_ROOT
33
34[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
35
36find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
37
38find $RPM_BUILD_ROOT/usr -type f -print |
39        sed "s@^$RPM_BUILD_ROOT@@g" |
40        grep -v perllocal.pod |
41        grep -v "\.packlist" > GSSAPI-%{version}-filelist
42if [ "$(cat GSSAPI-%{version}-filelist)X" = "X" ] ; then
43    echo "ERROR: EMPTY FILE LIST"
44    exit -1
45fi
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%check
51make test
52
53%files -f GSSAPI-%{version}-filelist
54%defattr(-,root,root,-)
55%dir %{perl_vendorarch}/GSSAPI
56%dir %{perl_vendorarch}/auto/GSSAPI
57
58%changelog
59* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26-2
60- rebuild with perl-5.12.3
61
62* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.26-1
63- initial package for Vine Linux
Note: See TracBrowser for help on using the repository browser.