source: projects/specs/branches/6/p/perl-GD/perl-GD-vl.spec @ 3736

Revision 3736, 3.0 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2
3Summary: A perl5 interface to Thomas Boutell's gd library
4Summary(ja): GD ライブラリの Perl 用インターフェイス
5Name: perl-GD
6Version: 2.35
7Release: 2%{?_dist_release}
8License: distributable
9Group: Development/Libraries
10Source0: http://search.cpan.org/CPAN/authors/id/L/LD/LDS/GD-%{version}.tar.gz
11Url: http://search.cpan.org/dist/GD/
12BuildRoot: %{_tmppath}/perl-GD-buildroot/
13BuildRequires: perl >= 5.6.0, gd-devel >= 2.0.20, libjpeg-devel
14BuildRequires: freetype2-devel, libpng-devel, zlib-devel
15BuildRequires: libX11-devel
16BuildRequires: libXpm-devel
17Requires: perl >= 5.6.0, gd >= 2.0.12, libjpeg, freetype2
18Requires: libpng, zlib
19
20%description
21This is a autoloadable interface module for libgd, a popular library
22for creating and manipulating PNG files.  With this library you can
23create PNG images on the fly or modify existing files.  Features
24include:
25
26a.  lines, polygons, rectangles and arcs, both filled and unfilled
27b.  flood fills
28c.  the use of arbitrary images as brushes and as tiled fill patterns
29d.  line styling (dashed lines and the like)
30e.  horizontal and vertical text rendering
31f.  support for transparency and interlacing
32
33For full information on usage, see the accompanying man and html
34documentation.
35
36# Provide perl-specific find-{provides,requires}.
37%define __find_provides /usr/lib/rpm/find-provides.perl
38%define __find_requires /usr/lib/rpm/find-requires.perl
39
40%prep
41%setup -q -n GD-%{version}
42
43%build
44CFLAGS="$RPM_OPT_FLAGS" \
45perl Makefile.PL --lib_gd_path=%{_libdir} INSTALLDIRS="vendor" << _OPT_
46y
47_OPT_
48make
49make test
50
51%clean 
52rm -rf %{buildroot}
53
54%install
55rm -rf %{buildroot}
56make DESTDIR=%{buildroot} install
57
58[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
59
60find %{buildroot}%{_prefix} -type f -print | 
61        sed "s@^%{buildroot}@@g" | 
62        grep -v perllocal.pod | 
63        grep -v "\.packlist" > %{name}-filelist
64if [ "$(cat %{name}-filelist)X" = "X" ] ; then
65    echo "ERROR: EMPTY FILE LIST"
66    exit -1
67fi
68
69find demos -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
70find bdf_scripts -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
71
72%files -f %{name}-filelist
73%defattr(-,root,root)
74%doc ChangeLog README* demos bdf_scripts
75%dir %{perl_vendorarch}/GD
76%dir %{perl_vendorarch}/auto/GD
77
78%changelog
79* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35-2
80- rebuild with perl-5.12.3
81- add BuildRequires: libX11-devel, libXpm-devel
82
83* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.35-1vl5
84- applied new versioning policy, spec in utf-8
85- built with perl-5.10.0
86
87* Sun Sep  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.35-0vl1
88- new upstream release
89- changed Group to Development/Libraries
90
91* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28-0vl1
92- new upstream release
93- added Japanese summary
94
95* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 2.19-0vl1
96- new upstream release
97- update {Build,}Requires
98
99* Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 2.11-0vl1
100- initial build
Note: See TracBrowser for help on using the repository browser.