source: projects/specs/branches/6/p/perl-File-MMagic/perl-File-MMagic-vl.spec @ 521

Revision 521, 4.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2%define perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
3%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
4
5Summary:      file command like perl5 module
6Summary(ja):  file コマンド風 perl5 モジュール
7Name:         perl-File-MMagic
8Version:      1.27
9Release:      2%{_dist_release}
10Url:          http://search.cpan.org/~knok/File-MMagic/
11License:      distributable
12Group:        Development/Libraries
13Source:       http://www.perl.com/CPAN/modules/by-module/File/File-MMagic-%{version}.tar.gz
14Requires:     perl >= 1:5.8.6
15Buildroot:    %{_tmppath}/%{name}-%{version}-root
16BuildArch:    noarch
17
18Vendor:       Project Vine
19Distribution: Vine Linux
20
21%description
22This module is to guess file type from its contents like file(1)
23command.
24
25%description -l ja
26このモジュールは、file(1)コマンドに相当する機能、すなわちファイルの内
27容からその種類を推測するためのものです。
28
29
30# Provide perl-specific find-{provides,requires}.
31%define __find_provides /usr/lib/rpm/find-provides.perl
32%define __find_requires /usr/lib/rpm/find-requires.perl
33
34%prep
35%setup -q -n File-MMagic-%{version}
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
39make
40make test
41
42%install
43[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT install
45
46[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
47
48find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
49
50find $RPM_BUILD_ROOT%{_prefix} -type f -print |
51        sed "s@^$RPM_BUILD_ROOT@@g" |
52        grep -v perllocal.pod |
53        grep -v "\.packlist" > File-MMagic-%{version}-filelist
54if [ "$(cat File-MMagic-%{version}-filelist)X" = "X" ] ; then
55    echo "ERROR: EMPTY FILE LIST"
56    exit -1
57fi
58
59%clean
60[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
61
62%files -f File-MMagic-%{version}-filelist
63%defattr(-,root,root)
64%doc COPYING README.en README.ja ChangeLog
65
66%changelog
67* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.27-2vl5
68- spec in utf-8
69
70* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.27-1vl5
71- rebuilt with perl 5.10.0
72- applied new versioning policy
73
74* Wed Sep 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.27-0vl2
75- chaneged Group to Development/Libraries
76
77* Sun May 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.27-0vl1
78- new upstrean release
79- chaneged Group to Development/Languages
80
81* Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.22-0vl2
82- rebuild on perl-5.8.6-0vl1
83- add many documents: COPYING, README.en, README.ja and ChangeLog
84- add Url tag
85- change build arch: noarch
86
87* Fri Sep 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-0vl1
88- updated to 1.22
89- Requires: perl >= 1:5.8.2
90
91* Tue May 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.21-1vl1
92- updated to 1.21
93- s/Copyright/License/
94- changed Group:Applications/CPAN (based on Fedora)
95
96* Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.16-3vl2
97- build with perl-5.8.2
98- add %%{perl_sitelib}/File directory in %%files
99
100* Fri May 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
101- 1.16-3vl1:
102- synced with rawhide
103  * Tue Dec 10 2002 Chip Turner <cturner@redhat.com>
104  - update to latest version from CPAN
105 
106  * Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
107  - automated release bump and build
108 
109  * Tue Aug  6 2002 Chip Turner <cturner@localhost.localdomain>
110  - update to 1.15
111 
112  * Fri Dec 7 2001 root <root@redhat.com>
113  - Spec file was autogenerated.
114
115* Sat Jun 16 2001 <sagami@vinelinux.org>
116- 1.12-0vl3: correct Group
117
118* Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
119- 1.12-0vl2
120- rebuilt with perl-5.6.1
121
122* Wed Jun 13 2001 Jun Nishii <jun@vinelinux.org> 1.12-0vl1
123- ver.up
124- modify for Vine
125       
126* Fri Dec 31 1999 Ryuji Abe <raeva@t3.rim.or.jp>
127- Installed correctly directories.
128
129* Sat Dec 11 1999 Ryuji Abe <raeva@t3.rim.or.jp>
130- Rebuild for RHL-6.1.
131
132* Thu Dec 02 1999 Ryuji Abe <raeva@t3.rim.or.jp>
133- Specified Obsoletes: File-MMagic.
134
135* Wed Dec 01 1999 Ryuji Abe <raeva@t3.rim.or.jp>
136- Fixed package name (Added prefix `perl-').
137
138* Thu Sep 09 1999 Ryuji Abe <raeva@t3.rim.or.jp>
139- First build.
Note: See TracBrowser for help on using the repository browser.