source: projects/specs/branches/6/p/perl-ExtUtils-PkgConfig/perl-ExtUtils-PkgConfig-vl.spec @ 3168

Revision 3168, 2.5 KB checked in by iwaim, 13 years ago (diff)

perl-ExtUtils?-PkgConfig?-1.12-1

Line 
1Summary:        Simplistic interface to pkg-config
2Name:           perl-ExtUtils-PkgConfig
3Version:        1.12
4Release:        1%{?_dist_release}
5
6Group:          Development/Libraries
7License:        LGPLv2+
8URL:            http://search.cpan.org/dist/ExtUtils-PkgConfig/
9Source0:        http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/ExtUtils-PkgConfig-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11
12BuildArch:      noarch
13BuildRequires:  pkgconfig
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Test::More)
16Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17Requires:       pkgconfig
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The pkg-config program retrieves information about installed libraries,
24usually for the purposes of compiling against and linking to them.
25
26ExtUtils::PkgConfig is a very simplistic interface to this utility,
27intended for use in the Makefile.PL of perl extensions which bind
28libraries that pkg-config knows. It is really just boilerplate code
29that you would've written yourself.
30
31
32%prep
33%setup -q -n ExtUtils-PkgConfig-%{version}
34
35
36%build
37%{__perl} Makefile.PL INSTALLDIRS=vendor
38make %{?_smp_mflags}
39
40
41%install
42rm -rf $RPM_BUILD_ROOT
43make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
44find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
45find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
46chmod -R u+w $RPM_BUILD_ROOT/*
47
48
49%check
50make test
51
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root,-)
59%doc Changes README
60%{perl_vendorlib}/ExtUtils/
61%{_mandir}/man3/*.3pm*
62
63
64%changelog
65* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.12-1
66- new upstream release
67- add Vendor and Distribution tags
68
69* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.08-1
70- new upstream release
71- build on perl-5.10
72
73* Wed Aug 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.07-5vl1
74- Initial build for Vine
75
76* Sat Sep  9 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-5
77- Rebuild for FC6.
78
79* Fri Feb 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-4
80- Rebuild for FC5 (perl 5.8.8).
81
82* Thu Dec 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-3
83- Dist tag.
84
85* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.07-2
86- rebuilt
87
88* Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.07-1
89- Update to 1.07.
90
91* Sun Oct  3 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-0.fdr.1
92- Update to 1.06.
93
94* Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
95- First build.
Note: See TracBrowser for help on using the repository browser.