source: projects/specs/branches/6/p/perl-ExtUtils-AutoInstall/perl-ExtUtils-AutoInstall-vl.spec @ 3218

Revision 3218, 2.0 KB checked in by iwaim, 13 years ago (diff)

perl-ExtUtils?-AutoInstall?-0.63-1

Line 
1Summary: Automatic install of dependencies via CPAN
2Name: perl-ExtUtils-AutoInstall
3Version: 0.63
4Release: 1%{?_dist_release}
5License: Artistic
6Group: Development/Libraries
7Source0: http://search.cpan.org/CPAN/authors/id/A/AU/AUTRIJUS/ExtUtils-AutoInstall-%{version}.tar.gz
8URL: http://www.cpan.org/dist/ExtUtils-AutoInstall/
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: perl >= 5.8.0, perl-version >= 0.28
11Requires: perl >= 5.8.0, perl-version >= 0.28
12Vendor: Project Vine
13Distribution: Vine Linux
14BuildArch: noarch
15
16%description
17This is the README file for ExtUtils::AutoInstall, a module to
18let Makefile.PL automatically install dependencies via CPAN or
19CPANPLUS.
20
21%prep
22%setup -q -n ExtUtils-AutoInstall-%{version}
23
24%build
25CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor << _OPT_
26n
27_OPT_
28
29make
30
31%install
32rm -rf %{buildroot}
33mkdir -p %{buildroot}%{_prefix}
34make DESTDIR=%{buildroot} install
35
36rm -f %{buildroot}%{perl_vendorarch}/perllocal.pod
37rm -f %{buildroot}%{perl_vendorarch}/auto/ExtUtils/AutoInstall/.packlist
38
39find %{buildroot}%{_prefix} -type f -print |
40        sed "s@^%{buildroot}@@g" |
41        grep -v perllocal.pod |
42        grep -v ^%{_mandir} > %{name}.files
43if [ "$(cat %{name}.files)X" = "X" ] ; then
44    echo "ERROR: EMPTY FILE LIST"
45    exit -1
46fi
47
48perllocalfile=`find %{buildroot} -name perllocal.pod`
49echo "mv $perllocalfile ."
50mv $perllocalfile .
51
52%clean
53rm -rf %{buildroot}
54
55%check
56make test
57
58
59%files -f %{name}.files
60%defattr(-,root,root)
61%doc AUTHORS Changes META.yml README SIGNATURE TODO perllocal.pod
62%{_mandir}/*/*
63%dir %{perl_vendorlib}/ExtUtils
64
65%changelog
66* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 0.63-1
67- build with perl 5.12.3
68- apply new versioning policy
69
70* Fri Feb 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.63-0vl1
71- new upstream release
72- changed Group to Development/Libraries
73
74* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 0.61-0vl1
75- new upstream release
76- build on perl-5.8.6-0vl1
77
78* Sun Jul  6 2003 IWAI Masaharu <iwai@alib.jp> 0.52-0vl1
79- first build for Vine Linux
80
Note: See TracBrowser for help on using the repository browser.