source: projects/specs/branches/6/p/perl-Data-ShowTable/perl-Data-ShowTable-vl.spec @ 3736

Revision 3736, 3.1 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define name perl-Data-ShowTable
2%define real_name Data-ShowTable
3%define version 3.3
4%define release 8%{?_dist_release}
5
6Summary: Perl 5 module to print arrays of data
7Name: %{name}
8Version: %{version}
9Release: %{release}
10License: GPL
11Group: Development/Libraries
12URL: http://www.cpan.org
13Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Data/%{real_name}-%{version}.tar.bz2
14Patch0: %{real_name}-3.3.patch.bz2
15BuildRequires:  perl
16BuildArch: noarch
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18
19%description
20ShowTable.pm, version 3.3, is a Perl 5 module which defines subroutines to
21print arrays of data in a nicely formatted listing, using one of four possible
22formats: simple table, boxed table, list style, and HTML-formatting (for
23World-Wide-Web output). See the documentation on ShowTable.pm for details on
24the formatting.
25
26%prep
27%setup -q -n %{real_name}-%{version}
28%patch0 -p1
29
30find . -type f | xargs perl -pi -e "s|/usr/bin/perl5|/usr/bin/perl|g"
31
32%build
33CFLAGS="%{optflags}" perl Makefile.PL INSTALLDIRS=vendor
34make
35
36%check
37make test
38
39%install
40[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
41make install DESTDIR=$RPM_BUILD_ROOT
42
43[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
44
45find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
46
47find $RPM_BUILD_ROOT/usr -type f -print |
48         sed "s@^$RPM_BUILD_ROOT@@g" |
49         grep -v perllocal.pod |
50         grep -v "\.packlist" > Data-ShowTable-%{version}-filelist
51if [ "$(cat Data-ShowTable-%{version}-filelist)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56%clean
57[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
58
59
60%files -f Data-ShowTable-%{version}-filelist
61%defattr(-,root,root)
62
63%changelog
64* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-8
65- rebuild with perl-5.12.3
66
67* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.3-7vl5
68- applied new versioning policy
69
70* Sat Jul 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3-6vl6
71- changed Group to Development/Libraries
72
73* Sat Jul 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3-6vl5
74- changed Group to Development/Languages
75
76* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 3.3-6vl4
77- rebuilt with perl-5.8.6
78
79* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 3.3-6vl3
80- changed ftp site of source
81
82* Fri Feb 01 2002 Satoshi MACHINO <machino@vinelinux.org> 3.3-6vl2
83- modified spec file
84
85* Sun Jan 27 2002 Satoshi MACHINO <machino@vinelinux.org> 3.3-6vl1
86- build on VineLinux
87- fixed spec file
88
89* Thu Nov 08 2001 FraníÐis Pons <fpons@mandrakesoft.com> 3.3-6mdk
90- added url tag.
91
92* Tue Oct 16 2001 Stefan van der Eijk <stefan@eijk.nu> 3.3-5mdk
93- BuildRequires: perl-devel
94
95* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.3-4mdk
96- Rebuild against latest perl.
97
98* Thu Aug 03 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.3-3mdk
99- macroszifications.
100- noarch.
101
102* Mon Apr  3 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 3.3-2mdk
103- fixed group
104- rebuild with new perl
105- fixed location
106- patched the source in order to build, the tests in order to test
107- fixed install process for correct man1 install
108
109* Sun Dec 05 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
110- First spec file
111
Note: See TracBrowser for help on using the repository browser.