source: projects/specs/branches/6/p/perl-Data-Buffer/perl-Data-Buffer-vl.spec @ 3736

Revision 3736, 1.7 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define module  Data-Buffer
2%define name    perl-%{module}
3%define version 0.04
4%define release 2%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Read/write buffer class
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14BuildArch:      noarch
15BuildRoot:      %{_tmppath}/%{name}-%{version}
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20%description
21Data::Buffer implements a low-level binary buffer in which you can get and
22put integers, strings, and other data.
23Internally the implementation is based on pack and unpack,
24such that Data::Buffer is really a layer on top of those built-in functions.
25
26%prep
27%setup -q -n %{module}-%{version}
28
29%build
30CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
31%{__make}
32
33%check
34%{__make} test
35
36%install
37rm -rf %{buildroot}
38%makeinstall
39rm -f %{buildroot}%{perl_archlib}/perllocal.pod
40rm -rf %{buildroot}%{perl_vendorarch}
41
42%clean
43rm -rf %{buildroot}
44
45%files
46%defattr(-,root,root)
47%doc README Changes
48%{_mandir}/man3*/*
49%{perl_vendorlib}/Data/*
50
51%changelog
52* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.04-2
53- rebuild with perl-5.12.3
54
55* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-1vl5
56- rebuild with perl 5.10
57- new versioning policy
58
59* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl1
60- built for VineSeed
61
62* Sun Mar 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.43
63- rebuilt to relase for VinePlus 4.2
64
65* Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.42
66- built for Vine 4.2 (testing)
Note: See TracBrowser for help on using the repository browser.