source: projects/specs/branches/6/p/perl-DBD-CSV/perl-DBD-CSV-vl.spec @ 3736

Revision 3736, 2.1 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
3
4# Provide perl-specific find-{provides,requires}.
5%define __find_provides /usr/lib/rpm/find-provides.perl
6%define __find_requires /usr/lib/rpm/find-requires.perl
7
8Summary: DBD-CSV module for perl
9Name: perl-DBD-CSV
10Version: 0.22
11Release: 2%{?_dist_release}
12License: distributable
13Group: Development/Libraries
14Source0: http://www.cpan.org/authors/id/J/JZ/JZUCKER/DBD-CSV-%{version}.tar.gz
15URL: http://search.cpan.org/~jzucker/DBD-CSV/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: perl >= 5.8.6, perl-DBI >= 1.0
18BuildRequires: perl-Text-CSV_XS perl-SQL-Statement
19Requires: perl >= 5.8.6, perl-DBI >= 1.0
20Requires: perl-SQL-Statement, perl-Text-CSV_XS
21BuildArch: noarch
22
23%description
24DBD-CSV module for perl
25
26%prep
27%setup -q -n DBD-CSV-%{version}
28
29%build
30CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
31make
32
33%check
34make test
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT%{_prefix}
42make DESTDIR=$RPM_BUILD_ROOT install
43
44find $RPM_BUILD_ROOT%{_prefix} -type f -print |
45        sed "s@^$RPM_BUILD_ROOT@@g" |
46        grep -v ^%{_mandir} |
47        grep -v perllocal.pod |
48        grep -v "\.packlist" > %{name}.files
49if [ "$(cat %{name}.files)X" = "X" ] ; then
50    echo "ERROR: EMPTY FILE LIST"
51    exit -1
52fi
53
54%files -f %{name}.files
55%defattr(-,root,root)
56%doc README ChangeLog
57%{_mandir}/*/*
58%dir %{perl_vendorlib}/Bundle/DBD
59%dir %{perl_vendorlib}/DBD
60
61%changelog
62* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-2
63- rebuild with perl-5.12.3
64
65* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-1
66- applied new versioning policy
67
68* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-0vl2
69- changed Group to Development/Libraries
70- s/Copyright/License/
71
72* Thu Sep  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-0vl1
73- updated to 0.22
74- added BuildRequires: perl-DBI
75- rebuild with perl 5.8.6
76- use vendor_perl dir
77
78* Sat Apr 13 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.2002-0vl1
79- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.