source: projects/specs/branches/6/p/perl-Crypt-SSLeay/perl-Crypt-SSLeay-vl.spec @ 3264

Revision 3264, 7.4 KB checked in by iwaim, 13 years ago (diff)

perl-Crypt-SSLeay-0.57-2vl6

Line 
1# -*- coding: utf-8 -*-
2%define origname Crypt-SSLeay
3
4Name:           perl-Crypt-SSLeay
5Summary:        Crypt::SSLeay - OpenSSL glue that provides LWP https support
6Version:        0.57
7Release:        2%{?_dist_release}
8License:        Perl's
9Group:          Development/Libraries
10Source0:        http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
11Patch1:         perl-Crypt-SSLeay-cryptdef.patch
12Patch2:         perl-Crypt-SSLeay-0.57-live-tests.patch
13Patch3:         perl-Crypt-SSLeay-Makefile_ssl1.patch
14URL:            http://search.cpan.org/dist/Crypt-SSLeay/
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  openssl-devel
18BuildRequires:  perl
19BuildRequires:  perl-URI
20BuildRequires:  perl-Test-Pod-Coverage
21BuildRequires:  perl-libwww-perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23Requires:       openssl
24
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: iwaim
28
29%description
30This perl module provides support for the https protocol under LWP, so
31that a LWP::UserAgent can make https GET & HEAD & POST
32requests. Please see perldoc LWP for more information on POST
33requests.
34
35The Crypt::SSLeay package contains Net::SSL, which is automatically
36loaded by LWP::Protocol::https on https requests, and provides the
37necessary SSL glue for that module to work.
38
39
40%prep
41%setup -q -n %{origname}-%{version}
42%patch1 -p1 -b .cryptdef
43%patch2 -p1
44%patch3 -p1 -b .make
45
46# Filter unwanted Provides:
47cat << EOF > %{name}-prov
48#!/bin/sh
49%{__perl_provides} $* |\
50  sed -e '/perl(DB)/d'
51EOF
52
53%define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
54chmod +x %{__perl_provides}
55
56
57%build
58if pkg-config openssl ; then
59  export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
60  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
61fi
62
63%{__perl} Makefile.PL --default --no-live-tests INC="$INC" \
64          LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
65make %{?_smp_mflags}
66
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
75find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
76find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
77find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
78chmod -R u+w $RPM_BUILD_ROOT/*
79chmod -R 644 eg/*
80chmod -R 644 certs/*
81
82#%check
83#make test
84
85
86%files
87%defattr(-,root,root,-)
88%doc README Changes eg/* certs/*
89%{perl_vendorarch}/auto/Crypt/
90%{perl_vendorarch}/Crypt/
91%{perl_vendorarch}/Net/
92%{_mandir}/man3/*.3*
93
94
95%changelog
96* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
97- build with perl 5.12.3
98
99* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
100- initial build for Vine Linux
101
102* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
103- rebuild against perl 5.10.1
104
105* Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
106- change Makefile for openssl 1.0, which couldn't be found properly before
107
108* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
109- rebuilt with new openssl
110
111* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
113
114* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
116
117* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
118- rebuild with new openssl
119
120* Mon Oct  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
121- add examples into doc
122
123* Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
124- fix patches for fuzz
125
126* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
127- rebuild for new perl
128
129* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
130- Autorebuild for GCC 4.3
131
132* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
133 - Rebuild for deps
134
135* Wed Dec  5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
136- Rebuild for new openssl
137
138* Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
139- Remove unnecessary BR: pkgconfig
140
141* Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
142- Fix buildroot per package review
143- Resolves: bz#226248
144
145* Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
146- Update to latest upstream version.
147- Remove old patch (patch applied to upstream)
148- Several fixes for package review:
149- Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
150- Apply patch to avoid prompting for input when building Makefile
151- Fix defattr line
152- Resolves: bz#226248
153
154* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
155- perl(ExtUtils::MakeMaker::Coverage) is now available
156
157* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
158- 0.56 is the latest CPAN version, not 0.55
159
160* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
161- Update to latest version from CPAN: 0.55
162- Remove two old patches, update lib64 patch for Makefile.PL changes.
163
164* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
165- New version: 0.53
166
167* Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
168- Resolves: bug#217138
169- fix a segfault on x86_64
170
171* Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
172- Filter out Provides perl(DB)
173- bug #205562
174
175* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
176- rebuild
177
178* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
179- bump again for double-long bug on ppc(64)
180
181* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
182- rebuilt for new gcc4.1 snapshot and glibc changes
183
184* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
185- rebuild for new perl-5.8.8 / gcc / glibc
186
187* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
188- rebuilt for new gcc
189
190* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
191- rebuilt for new gcj
192
193* Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
194- rebuilt against new openssl
195- added missing SSL_library_init()
196
197* Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
198- Own more installed dirs (#73908).
199- Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
200- Require perl(:MODULE_COMPAT_*).
201- Run tests in the %%check section.
202- Fix License, Source0, URL, and Group tags.
203
204* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
205- remove brp-compress
206
207* Tue Mar  8 2005 Joe Orton <jorton@redhat.com> 0.51-6
208- rebuild
209
210* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
211- build for FC3
212
213* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
214- build for RHEL3 U4
215
216* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
217- rebuilt
218
219* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
220- rebuilt
221
222* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
223- update to upstream 0.51
224
225* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
226- rebuilt
227
228* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com>
229- pass openssl includes to make as INC and ldflags in as LDFLAGS
230
231* Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
232- patch to support /usr/lib64 before /usr/lib
233
234* Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
235- rebuild
236
237* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
238- automated release bump and build
239
240* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
241- description update
242
243* Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
244- move to 0.39
245
246* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
247- automated rebuild
248
249* Fri Dec 7 2001 root <root@redhat.com>
250- Spec file was autogenerated.
251
Note: See TracBrowser for help on using the repository browser.