source: projects/specs/branches/6/p/perl-Crypt-DSA/perl-Crypt-DSA-vl.spec @ 521

Revision 521, 2.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define module  Crypt-DSA
2%define name    perl-%{module}
3%define version 0.14
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        DSA Signatures and Key Generation
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14Requires:       perl-Digest-SHA1, perl(Math::BigInt)
15Requires:       perl-Convert-PEM
16Requires:       perl-Data-Buffer
17
18BuildArch:      noarch
19BuildRoot:      %{_tmppath}/%{name}-%{version}
20BuildRequires:  perl-Digest-SHA1, perl(Math::BigInt)
21BuildRequires:  perl-Convert-PEM
22BuildRequires:  perl-Data-Buffer
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26
27%description
28Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
29signature verification system. The implementation itself is pure Perl,
30although the heavy-duty mathematics underneath are provided by
31the Math::Pari library.
32
33This package provides DSA signing, signature verification,
34and key generation.
35
36%prep
37%setup -q -n %{module}-%{version}
38
39%build
40CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
41%{__make}
42
43%check
44echo " "
45echo "Several Minutes is needed for test. Please wait."
46echo " "
47%{__make} test
48
49%install
50rm -rf %{buildroot}
51%makeinstall
52# rm -f %{buildroot}%{perl_archlib}/perllocal.pod
53# rm -rf %{buildroot}%{perl_vendorarch}
54
55%clean
56rm -rf %{buildroot}
57
58%files
59%defattr(-,root,root)
60%doc README Changes
61%{_mandir}/man3*/*
62%{perl_vendorlib}/Crypt/*
63
64%changelog
65* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-1vl5
66- rebuild with perl 5.10
67- new versioning policy
68
69* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl1
70- built for VineSeed
71
72* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.43
73- add Requires: perl-Convert-PEM/perl-Data-Buffer
74
75* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.42
76- built for Vine 4.2 (testing)
77- 1st build for Vine
78
79
Note: See TracBrowser for help on using the repository browser.