source: projects/specs/branches/6/p/perl-Crypt-DES_EDE3/perl-Crypt-DES_EDE3-vl.spec @ 3736

Revision 3736, 2.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define module  Crypt-DES_EDE3
2%define name    perl-%{module}
3%define version 0.01
4%define release 2%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Triple-DES EDE encryption/decryption
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14Requires:       perl-Crypt-DES
15
16Buildrequires:  perl-Crypt-DES
17BuildArch:      noarch
18BuildRoot:      %{_tmppath}/%{name}-%{version}
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%description
24Crypt::DES_EDE3 implements DES-EDE3 encryption.
25This is triple-DES encryption where an encrypt operation is
26encrypt-decrypt-encrypt, and decrypt is decrypt-encrypt-decrypt.
27This implementation uses Crypt::DES to do its dirty DES work,
28and simply provides a wrapper around that module: setting up
29the individual DES ciphers, initializing the keys, and performing
30the encryption/decryption steps.
31
32DES-EDE3 encryption requires a key size of 24 bytes.
33
34You're probably best off not using this module directly,
35as the encrypt and decrypt methods expect 8-octet blocks.
36You might want to use the module in conjunction with Crypt::CBC,
37for example. This would be DES-EDE3-CBC, or triple-DES in outer CBC mode.
38
39#'
40%prep
41%setup -q -n %{module}-%{version}
42
43%build
44CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
45%{__make}
46
47# %check
48# %{__make} test
49
50%install
51rm -rf %{buildroot}
52%makeinstall
53rm -f %{buildroot}%{perl_archlib}/perllocal.pod
54# rm -rf %{buildroot}%{perl_vendorarch}
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%doc README Changes
62%{_mandir}/man3*/*
63%{perl_vendorlib}/Crypt/*
64
65
66%changelog
67* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.01-2
68- rebuild with perl-5.12.3
69
70* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-1vl5
71- rebuild with perl 5.10
72- new versioning policy
73
74* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl1
75- built for VineSeed
76
77* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.43
78- add Requires: and Buildrequires: perl-Crypt-DES
79
80* Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.42
81- built for Vine 4.2 (testing)
82
Note: See TracBrowser for help on using the repository browser.