source: projects/specs/branches/6/p/perl-Config-IniFiles/perl-Config-IniFiles-vl.spec @ 3736

Revision 3736, 1.6 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define pkgname Config-IniFiles
2
3Summary:        A perl module for reading .ini-style configuration files.
4Name:           perl-%{pkgname}
5Version:        2.39
6Release:        2%{?_dist_release}
7Group:          Development/Libraries
8License:        distributable
9URL:            http://config-inifiles.sourceforge.net/
10Source0:        %{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13
14%description
15Config::IniFiles provides a way to have readable configuration files
16outside your Perl script. Configurations can be imported (inherited,
17stacked,...), sections can be grouped, and settings can be accessed
18from a tied hash.
19
20%prep
21%setup -q -n %{pkgname}-%{version}
22
23%build
24CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
25make
26make test
27
28%install
29rm -rf $RPM_BUILD_ROOT
30make install
31
32[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
33
34find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
35        sed "s@^$RPM_BUILD_ROOT@@g" | \
36        grep -v perllocal.pod | \
37        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
38if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
39    echo "ERROR: EMPTY FILE LIST"
40    exit -1
41fi
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files -f %{pkgname}-%{version}-filelist
47%defattr(-,root,root)
48%doc README MANIFEST
49
50%changelog
51* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.39-2
52- rebuild with perl-5.12.3
53
54* Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.39-1
55- apply new versioning policy
56
57* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.39-0vl1
58- new upstream release
59
60* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.38-0vl1
61- initial build for Vine Linux
62
Note: See TracBrowser for help on using the repository browser.