source: projects/specs/branches/6/p/perl-Class-Singleton/perl-Class-Singleton-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           perl-Class-Singleton
2Version:        1.4
3Release:        6%{?_dist_release}
4Summary:        Implementation of a "Singleton" class
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Class-Singleton/
8Source0:        http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(Test::More)
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15%description
16This is the Class::Singleton module. A Singleton describes an object class
17that can have only one instance in any system. An example of a Singleton
18might be a print spooler or system registry. This module implements a
19Singleton class from which other classes can be derived. By itself, the
20Class::Singleton module does very little other than manage the
21instantiation of a single object. In deriving a class from
22Class::Singleton, your module will inherit the Singleton instantiation
23method and can implement whatever specific functionality is required.
24
25%prep
26%setup -q -n Class-Singleton-%{version}
27
28%build
29%{__perl} Makefile.PL INSTALLDIRS=vendor
30make %{?_smp_mflags}
31
32%install
33rm -rf $RPM_BUILD_ROOT
34
35make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
36
37find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
38find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
39
40%{_fixperms} $RPM_BUILD_ROOT/*
41
42%check
43make test
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(-,root,root,-)
50%doc Changes README
51%{perl_vendorlib}/*
52%{_mandir}/man3/*
53
54%changelog
55* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
56- initial build for Vine Linux
57
58* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
59- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
60
61* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
62- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
63
64* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
65- Rebuild for perl 5.10 (again)
66
67* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
68- rebuild for new perl
69
70* Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
71- Update to 1.4.
72- Update License tag.
73- Drop our copy of the license text.
74- Improve Summary.
75- Make description match cpanspec output.
76- BR Test::More.
77
78* Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
79- Use fixperms macro instead of our own chmod incantation.
80- BR ExtUtils::MakeMaker.
81
82* Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
83- Canonicalize Source0 URL.
84- Fix find option order.
85
86* Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
87- Fix permissions on Singleton.pm.
88
89* Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
90- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.