source: projects/specs/branches/6/p/perl-Carp-Clan/perl-Carp-Clan-vl.spec @ 3164

Revision 3164, 2.4 KB checked in by iwaim, 13 years ago (diff)

perl-Carp-Clan-6.04-1

Line 
1%define perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
2
3Summary: Report errors from perspective of caller of a "clan" of modules for Perl
4Name: perl-Carp-Clan
5Version: 6.04
6Release: 1%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/Carp-Clan-%{version}.tar.gz
10URL: http://search.cpan.org/~stbey/Carp-Clan/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5
15BuildRequires: perl-Test-Exception
16Requires: perl >= 5
17Conflicts: perl-Bit-Vector <= 6.3
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23This module reports errors from the perspective of the caller of a
24"clan" of modules, similar to "Carp.pm" itself. But instead of giving
25it a number of levels to skip on the calling stack, you give it a
26pattern to characterize the package names of the "clan" of modules
27which shall never be blamed for any error. :-)
28
29So these modules stick together like a "clan" and any error which
30occurs will be blamed on the "outsider" script or modules not belonging
31to this "clan".
32
33# Provide perl-specific find-{provides,requires}.
34%define __find_provides /usr/lib/rpm/find-provides.perl
35%define __find_requires /usr/lib/rpm/find-requires.perl
36
37%prep
38%setup -q -n Carp-Clan-%{version}
39
40%build
41CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
42make
43
44%install
45rm -rf %{buildroot}
46make DESTDIR=%{buildroot} pure_install
47
48[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
49
50find %{buildroot}%{_prefix} -type f -print |
51        sed "s@^%{buildroot}@@g" |
52        grep -v perllocal.pod |
53        grep -v %{_mandir}    |
54        grep -v "\.packlist" > %{name}-filelist
55if [ "$(cat %{name}-filelist)X" = "X" ] ; then
56    echo "ERROR: EMPTY FILE LIST"
57    exit -1
58fi
59
60%check
61make test
62
63%clean
64rm -rf %{buildroot}
65
66%files -f %{name}-filelist
67%defattr(-,root,root)
68%doc Changes license/Artistic.txt license/GNU_GPL.txt README
69%dir %{perl_vendorlib}/Carp
70%{_mandir}/man3/Carp::Clan.3pm*
71
72%changelog
73* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 6.04-1
74- new upstrem release
75- add Vendor and Distribution tags
76- update files in doc
77
78* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.00-1vl5
79- new upstream release
80- addede BuildRequires: perl-Test-Exception
81
82* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.3-1vl5
83- applied new versioning policy
84- built with perl-5.10.0
85
86* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.3-0vl1
87- initial release
88
Note: See TracBrowser for help on using the repository browser.