source: projects/specs/branches/6/p/perl-Bit-Vector/perl-Bit-Vector-vl.spec @ 3170

Revision 3170, 2.8 KB checked in by iwaim, 13 years ago (diff)

perl-Bit-Vector-7.1-1

Line 
1Summary: Efficient bit vector, set of integers and "big int" math library
2Name: perl-Bit-Vector
3Version: 7.1
4Release: 1%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7URL: http://search.cpan.org/~stbey/Bit-Vector/
8Source0: http://www.cpan.org/authors/id/STBEY/Bit-Vector-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 0:5.00503
12BuildRequires: perl-Carp-Clan >= 5.3
13Requires: perl
14Requires: perl-Carp-Clan >= 5.3
15Conflicts: perl-Date-Calc < 5.0
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21Bit::Vector is an efficient C library which allows you to handle
22bit vectors, sets (of integers), "big integer arithmetic" and
23boolean matrices, all of arbitrary sizes.
24
25The library is efficient (in terms of algorithmical complexity)
26and therefore fast (in terms of execution speed) for instance
27through the widespread use of divide-and-conquer algorithms.
28
29The package also includes an object-oriented Perl module for
30accessing the C library from Perl, and optionally features
31overloaded operators for maximum ease of use.
32
33The C library can nevertheless be used stand-alone, without Perl.
34
35%prep
36%setup -q -n Bit-Vector-%{version}
37
38%build
39CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT pure_install
45
46find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
47        sed "s@^$RPM_BUILD_ROOT@@g" | \
48        grep -v perllocal.pod | \
49        grep -v %{_mandir} | \
50        grep -v "\.packlist" > Bit-Vector-%{version}-filelist
51if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
56find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
57
58%check
59make test
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files -f Bit-Vector-%{version}-filelist
65%defattr(-,root,root)
66%doc CHANGES.txt CREDITS.txt README.txt examples Artistic.txt GNU_GPL.txt GNU_LGPL.txt
67%dir %{perl_vendorarch}/auto/Bit
68%dir %{perl_vendorarch}/auto/Bit/Vector
69%dir %{perl_vendorarch}/Bit
70%dir %{perl_vendorarch}/Bit/Vector
71%{_mandir}/man3/*3pm*
72
73%changelog
74* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 7.1-1
75- new upstream release
76- add Vendor and Distribution tags
77
78* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
79- new upstream release
80- built with perl-5.10.0
81
82* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
83- new upstream release
84- update Summary and description
85- add Requires: perl-Carp-Clan >= 5.3
86- add some license documents
87
88* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
89- version up to 6.3
90- add directories in %%files section
91- add some documents
92- add Conflicts: perl-Date-Calc < 5.0
93
94* Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
95- build Rawhide-6.1-12 for Vine Linux
96
97* Wed Jan 30 2002 cturner@redhat.com
98- Specfile autogenerated
99
Note: See TracBrowser for help on using the repository browser.