source: projects/specs/branches/6/p/perl-AppConfig/perl-AppConfig-vl.spec @ 3736

Revision 3736, 2.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1Summary: Perl5 module for reading configuration files and parsing command line arguments
2Name: perl-AppConfig
3Version: 1.66
4Release: 2%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7Source0: http://www.cpan.org/authors/id/ABW/AppConfig-%{version}.tar.gz
8URL: http://search.cpan.org/~abw/AppConfig/
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildArch: noarch
11BuildRequires: perl >= 5.004
12
13%description
14AppConfig is a bundle of Perl5 modules for reading configuration files
15and parsing command line arguments.  This is a descendant of, and
16supercedes the App::Config module.  Functionality is extended over the
17final version of App::Config (1.09) and includes many new features.  This
18module has been developed and in the process, renamed, as part of an
19effort to unify the various Perl modules for parsing configuration files
20and command line arguments.
21
22
23%prep
24%setup -q -n AppConfig-%{version}
25
26%build
27CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
28make
29
30%install
31rm -rf $RPM_BUILD_ROOT
32mkdir -p $RPM_BUILD_ROOT%{_prefix}
33make DESTDIR=$RPM_BUILD_ROOT install
34
35find $RPM_BUILD_ROOT%{_prefix} -type f -print |
36        sed "s@^$RPM_BUILD_ROOT@@g" |
37        grep -v ^%{_mandir} |
38        grep -v perllocal.pod |
39        grep -v "\.packlist" > %{name}.files
40if [ "$(cat %{name}.files)X" = "X" ] ; then
41    echo "ERROR: EMPTY FILE LIST"
42    exit -1
43fi
44
45%check
46make test
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files -f %{name}.files
52%defattr(-,root,root)
53%doc README Changes TODO
54%dir %{perl_vendorlib}/AppConfig
55%{_mandir}/man3/*3pm*
56
57%changelog
58* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.65-2
59- rebuild with perl-5.12.3
60
61* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 1.65-1vl5
62- applied new versioning policy
63
64* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.65-0vl1
65- new upstream release
66- s/Copyright/License/
67- changed Group to Development/Libraries
68- installed modules to vendor_perl dir
69
70* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.56-0vl1
71- new upstream release
72
73* Mon Dec 29 2003 IWAI, Masaharu <iwai@alib.jp> 1.55-0vl1
74- new upstream release
75- drop obsolete patch (Patch0): perl-AppConfig-pod-syntax.patch
76- drop obsolete examples directory in %%doc dir
77
78* Tue Apr 29 2003 IWAI Masaharu <iwai@alib.jp> 1.52-0vl2
79- build with perl-5.8.0
80
81* Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.52-0vl1
82- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.